aboutsummaryrefslogtreecommitdiffstats
path: root/keyserver/ksutil.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-04-26 21:48:29 +0000
committerDavid Shaw <[email protected]>2006-04-26 21:48:29 +0000
commite87d36ccf624d2bbb731a0187e0bcff94243d83d (patch)
tree929d931a82d14d4af3389f643355863f9757d047 /keyserver/ksutil.h
parent* keyserver.c: Fix build problem with platforms that stick libcurl in (diff)
downloadgnupg-e87d36ccf624d2bbb731a0187e0bcff94243d83d.tar.gz
gnupg-e87d36ccf624d2bbb731a0187e0bcff94243d83d.zip
* Makefile.am: Don't build gpgkeys_http or gpgkeys_(old)hkp any longer as
this is done via curl or fake-curl. * ksutil.h, ksutil.c, gpgkeys_hkp.c, gpgkeys_curl.c: Minor #include tweaks as FAKE_CURL is no longer meaningful.
Diffstat (limited to 'keyserver/ksutil.h')
-rw-r--r--keyserver/ksutil.h7
1 files changed, 1 insertions, 6 deletions
diff --git a/keyserver/ksutil.h b/keyserver/ksutil.h
index 0ef14f595..16c1ebf88 100644
--- a/keyserver/ksutil.h
+++ b/keyserver/ksutil.h
@@ -1,5 +1,5 @@
/* ksutil.h
- * Copyright (C) 2004, 2005 Free Software Foundation, Inc.
+ * Copyright (C) 2004, 2005, 2006 Free Software Foundation, Inc.
*
* This file is part of GNUPG.
*
@@ -25,10 +25,8 @@
#ifdef HAVE_LIBCURL
#include <curl/curl.h>
#else
-#ifdef FAKE_CURL
#include "curl-shim.h"
#endif
-#endif
/* MAX_LINE must be at least 1 larger than the largest item we expect
to receive, including the name tag ("COMMAND", "PORT", etc) and
@@ -107,7 +105,6 @@ const char *ks_action_to_string(enum ks_action action);
void print_nocr(FILE *stream,const char *str);
enum ks_search_type classify_ks_search(const char **search);
-#if defined (HAVE_LIBCURL) || defined (FAKE_CURL)
int curl_err_to_gpg_err(CURLcode error);
struct curl_writer_ctx
@@ -130,6 +127,4 @@ struct curl_writer_ctx
size_t curl_writer(const void *ptr,size_t size,size_t nmemb,void *cw_ctx);
void curl_writer_finalize(struct curl_writer_ctx *ctx);
-#endif
-
#endif /* !_KSUTIL_H_ */