aboutsummaryrefslogtreecommitdiffstats
path: root/keyserver/ksutil.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-04-16 18:50:46 +0000
committerDavid Shaw <[email protected]>2005-04-16 18:50:46 +0000
commit5748f595b0c71eee5fa70f67e6671dfed939462e (patch)
tree384623c5d6479a02bd06c9657ff3e2be80f9b0fc /keyserver/ksutil.h
parent* configure.ac: Add --disable-old-hkp option that can be used along (diff)
downloadgnupg-5748f595b0c71eee5fa70f67e6671dfed939462e.tar.gz
gnupg-5748f595b0c71eee5fa70f67e6671dfed939462e.zip
* gpgkeys_curl.c (main): If the http-proxy option is given without any
arguments, try to get the proxy from the environment. * ksutil.h, ksutil.c (curl_err_to_gpg_err, curl_writer): Copy from gpgkeys_curl.c. * gpgkeys_oldhkp.c: Copy from gpgkeys_hkp.c.
Diffstat (limited to 'keyserver/ksutil.h')
-rw-r--r--keyserver/ksutil.h14
1 files changed, 14 insertions, 0 deletions
diff --git a/keyserver/ksutil.h b/keyserver/ksutil.h
index 120e15dc2..a859687d9 100644
--- a/keyserver/ksutil.h
+++ b/keyserver/ksutil.h
@@ -21,6 +21,12 @@
#ifndef _KSUTIL_H_
#define _KSUTIL_H_
+#ifdef FAKE_CURL
+#include "curl-shim.h"
+#else
+#include <curl/curl.h>
+#endif
+
#define GET 0
#define SEND 1
#define SEARCH 2
@@ -47,6 +53,12 @@
#define BEGIN "-----BEGIN PGP PUBLIC KEY BLOCK-----"
#define END "-----END PGP PUBLIC KEY BLOCK-----"
+#ifdef __riscos__
+#define HTTP_PROXY_ENV "GnuPG$HttpProxy"
+#else
+#define HTTP_PROXY_ENV "http_proxy"
+#endif
+
struct keylist
{
char str[MAX_LINE];
@@ -88,5 +100,7 @@ void free_ks_options(struct ks_options *opt);
int parse_ks_options(char *line,struct ks_options *opt);
const char *ks_action_to_string(enum ks_action action);
void print_nocr(FILE *stream,const char *str);
+int curl_err_to_gpg_err(CURLcode error);
+size_t curl_writer(const void *ptr,size_t size,size_t nmemb,void *stream);
#endif /* !_KSUTIL_H_ */