aboutsummaryrefslogtreecommitdiffstats
path: root/keyserver/gpgkeys_hkp.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-31 03:52:02 +0000
committerDavid Shaw <[email protected]>2003-05-31 03:52:02 +0000
commit0a86b45b9d4b8a6f34e2dcee80bf06368d478a85 (patch)
treee0a782a610e258ca854da1072fdb39b9054329f4 /keyserver/gpgkeys_hkp.c
parent* Makefile.am: Some cleanup, and use DLLIBS for -ldl. (diff)
downloadgnupg-0a86b45b9d4b8a6f34e2dcee80bf06368d478a85.tar.gz
gnupg-0a86b45b9d4b8a6f34e2dcee80bf06368d478a85.zip
* gpgkeys_hkp.c, gpgkeys_ldap.c: #include <getopt.h> if it is available.
Also include extern references for optarg and optind since there is no guarantee that any header file will include them. Standards? We don't need no stinkin' standards * Makefile.am: Use @GETOPT@ to pull in libiberty on those platforms that need it.
Diffstat (limited to 'keyserver/gpgkeys_hkp.c')
-rw-r--r--keyserver/gpgkeys_hkp.c6
1 files changed, 6 insertions, 0 deletions
diff --git a/keyserver/gpgkeys_hkp.c b/keyserver/gpgkeys_hkp.c
index 96c81985a..51487d17f 100644
--- a/keyserver/gpgkeys_hkp.c
+++ b/keyserver/gpgkeys_hkp.c
@@ -25,11 +25,17 @@
#include <stdlib.h>
#include <errno.h>
#include <unistd.h>
+#ifdef HAVE_GETOPT_H
+#include <getopt.h>
+#endif
#define INCLUDED_BY_MAIN_MODULE 1
#include "util.h"
#include "http.h"
#include "keyserver.h"
+extern char *optarg;
+extern int optind;
+
#define GET 0
#define SEND 1
#define SEARCH 2