aboutsummaryrefslogtreecommitdiffstats
path: root/keyserver/gpgkeys_curl.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-02-11 18:05:13 +0000
committerDavid Shaw <[email protected]>2005-02-11 18:05:13 +0000
commit25001837e9f6a3727394f2f639aff7a0151bbbda (patch)
treef924db50311c1819f6e4c803704c1baadaaa7ad2 /keyserver/gpgkeys_curl.c
parent* configure.ac: Add --enable-fake-curl option to help test no-curl HTTP. (diff)
downloadgnupg-25001837e9f6a3727394f2f639aff7a0151bbbda.tar.gz
gnupg-25001837e9f6a3727394f2f639aff7a0151bbbda.zip
* curl-shim.h, curl-shim.c: New. This is code to fake the curl API in
terms of the current HTTP iobuf API. * gpgkeys_curl.c [FAKE_CURL], Makefile.am: If FAKE_CURL is set, link with the iobuf code rather than libcurl.
Diffstat (limited to 'keyserver/gpgkeys_curl.c')
-rw-r--r--keyserver/gpgkeys_curl.c4
1 files changed, 4 insertions, 0 deletions
diff --git a/keyserver/gpgkeys_curl.c b/keyserver/gpgkeys_curl.c
index 71ee97260..7c3dcb3c7 100644
--- a/keyserver/gpgkeys_curl.c
+++ b/keyserver/gpgkeys_curl.c
@@ -27,7 +27,11 @@
#ifdef HAVE_GETOPT_H
#include <getopt.h>
#endif
+#ifdef FAKE_CURL
+#include "curl-shim.h"
+#else
#include <curl/curl.h>
+#endif
#include "keyserver.h"
#include "ksutil.h"