aboutsummaryrefslogtreecommitdiffstats
path: root/intl/relocatable.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-07-27 15:12:00 +0000
committerWerner Koch <[email protected]>2004-07-27 15:12:00 +0000
commit5d4fb5734727e493fa8119f0d2d0f21ebc7452a7 (patch)
treea2f907826fed2c350c048db21fc0c8d8e2850fc2 /intl/relocatable.c
parent* keylist.c (list_keyblock_print): Always use the new listing format where (diff)
downloadgnupg-5d4fb5734727e493fa8119f0d2d0f21ebc7452a7.tar.gz
gnupg-5d4fb5734727e493fa8119f0d2d0f21ebc7452a7.zip
* configure.ac (AM_GNU_GETTEXT_VERSION): New.
(min_automake_version): New. * LINGUAS: Added all languages we supported in 1.2.5. Copied all po files from 1.2.5. * autogen.sh: Updated to the modern version, grepping the required tool versions from configure.ac.
Diffstat (limited to 'intl/relocatable.c')
-rw-r--r--intl/relocatable.c14
1 files changed, 12 insertions, 2 deletions
diff --git a/intl/relocatable.c b/intl/relocatable.c
index 16f79a528..bf7c70854 100644
--- a/intl/relocatable.c
+++ b/intl/relocatable.c
@@ -42,7 +42,12 @@
#ifdef NO_XMALLOC
# define xmalloc malloc
#else
-# include "xmalloc.h"
+# include "xalloc.h"
+#endif
+
+#if defined _WIN32 || defined __WIN32__
+# define WIN32_LEAN_AND_MEAN
+# include <windows.h>
#endif
#if DEPENDS_ON_LIBCHARSET
@@ -152,6 +157,8 @@ set_relocation_prefix (const char *orig_prefix_arg, const char *curr_prefix_arg)
#endif
}
+#if !defined IN_LIBRARY || (defined PIC && defined INSTALLDIR)
+
/* Convenience function:
Computes the current installation prefix, based on the original
installation prefix, the original installation directory of a particular
@@ -266,6 +273,8 @@ compute_curr_prefix (const char *orig_installprefix,
}
}
+#endif /* !IN_LIBRARY || PIC */
+
#if defined PIC && defined INSTALLDIR
/* Full pathname of shared library, or NULL. */
@@ -304,7 +313,8 @@ DllMain (HINSTANCE module_handle, DWORD event, LPVOID reserved)
static void
find_shared_library_fullname ()
{
-#ifdef __linux__
+#if defined __linux__ && __GLIBC__ >= 2
+ /* Linux has /proc/self/maps. glibc 2 has the getline() function. */
FILE *fp;
/* Open the current process' maps file. It describes one VMA per line. */