aboutsummaryrefslogtreecommitdiffstats
path: root/include/util.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
committerWerner Koch <[email protected]>2004-10-21 16:56:22 +0000
commit0ebf79c824a0eebff35f757f85608e3dd7750ac3 (patch)
tree915cea6a021349865c78dfb0bed4b327bf4b4202 /include/util.h
parent* g10.c (parse_list_options): Fix non-constant initializer so we can build (diff)
downloadgnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.tar.gz
gnupg-0ebf79c824a0eebff35f757f85608e3dd7750ac3.zip
* configure.ac: Remove the check for asprintf
* app-common.h (app_openpgp_storekey: Add prototype. * app-openpgp.c (do_sign): Replace asprintf by direct allocation. This avoids problems with missing vasprintf implementations. * card-util.c (generate_card_keys): Add a #warning for gnupg 1.9 and use the same string there. * util.h [!HAVE_VASPRINTF]: Removed prototype. * vasprintf.c: Removed. It was used only at one place and I don't want to get into build problems in 1.4.
Diffstat (limited to '')
-rw-r--r--include/util.h9
1 files changed, 0 insertions, 9 deletions
diff --git a/include/util.h b/include/util.h
index a2c65e497..ba493b1be 100644
--- a/include/util.h
+++ b/include/util.h
@@ -245,15 +245,6 @@ int asprintf (char **buf, const char *fmt, ...);
/*-- Replacement functions from funcname.c --*/
-#if !HAVE_VASPRINTF
-int asprintf (char **result, const char *format, ...)
-#if defined (__riscos__) \
- || (__GNUC__ > 2 || (__GNUC__ == 2 && __GNUC_MINOR__ >= 5 ))
- __attribute__ ((format (printf,2,3)))
-#endif
- ;
-
-#endif
/******** some macros ************/