aboutsummaryrefslogtreecommitdiffstats
path: root/include/mpi.h
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>1997-12-23 17:30:18 +0000
committerWerner Koch <[email protected]>1997-12-23 17:30:18 +0000
commitc351df1dc5294dfd81619fea3c1ff6a7e25ba774 (patch)
treeb0fa86a4d1455e53c3a51d696eac51abe0308b0d /include/mpi.h
parentNow created by config.links (diff)
downloadgnupg-c351df1dc5294dfd81619fea3c1ff6a7e25ba774.tar.gz
gnupg-c351df1dc5294dfd81619fea3c1ff6a7e25ba774.zip
changed configuration stuff, replaced some Makefile.am by distfiles.
Diffstat (limited to '')
-rw-r--r--include/mpi.h12
1 files changed, 12 insertions, 0 deletions
diff --git a/include/mpi.h b/include/mpi.h
index fd93f3075..4e25ab201 100644
--- a/include/mpi.h
+++ b/include/mpi.h
@@ -45,6 +45,18 @@ int mpi_debug_mode;
#define BYTES_PER_MPI_LIMB2 8
typedef unsigned long int mpi_limb_t;
typedef signed long int mpi_limb_signed_t;
+#elif defined(__hppa__)
+ #define BITS_PER_MPI_LIMB 32
+ #define BYTES_PER_MPI_LIMB 4
+ #define BYTES_PER_MPI_LIMB2 8
+ typedef unsigned long int mpi_limb_t;
+ typedef signed long int mpi_limb_signed_t;
+#elif defined(__alpha__)
+ #define BITS_PER_MPI_LIMB 64
+ #define BYTES_PER_MPI_LIMB 8
+ #define BYTES_PER_MPI_LIMB2 16
+ typedef unsigned long int mpi_limb_t;
+ typedef signed long int mpi_limb_signed_t;
#else
#error add definions for this machine here
#endif