aboutsummaryrefslogtreecommitdiffstats
path: root/gl/vasprintf.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2005-06-01 15:48:03 +0000
committerWerner Koch <[email protected]>2005-06-01 15:48:03 +0000
commit5703db4d03b1449ef25cfb568efc08bcbb9634b4 (patch)
treeda00873c2e490272f77a9fd9f8fb4804db02074d /gl/vasprintf.c
parent* configure.ac (gl_INIT): Add gnulib stuff. (diff)
downloadgnupg-5703db4d03b1449ef25cfb568efc08bcbb9634b4.tar.gz
gnupg-5703db4d03b1449ef25cfb568efc08bcbb9634b4.zip
Add stuff from gnulib.
Diffstat (limited to '')
-rw-r--r--gl/vasprintf.c42
1 files changed, 42 insertions, 0 deletions
diff --git a/gl/vasprintf.c b/gl/vasprintf.c
new file mode 100644
index 000000000..149c29242
--- /dev/null
+++ b/gl/vasprintf.c
@@ -0,0 +1,42 @@
+/* Formatted output to strings.
+ Copyright (C) 1999, 2002 Free Software Foundation, Inc.
+
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2, or (at your option)
+ any later version.
+
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License along
+ with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
+
+#ifdef HAVE_CONFIG_H
+# include <config.h>
+#endif
+
+/* Specification. */
+#include "vasprintf.h"
+
+#include <stdlib.h>
+
+#include "vasnprintf.h"
+
+int
+vasprintf (char **resultp, const char *format, va_list args)
+{
+ size_t length;
+ char *result = vasnprintf (NULL, &length, format, args);
+ if (result == NULL)
+ return -1;
+
+ *resultp = result;
+ /* Return the number of resulting bytes, excluding the trailing NUL.
+ If it wouldn't fit in an 'int', vasnprintf() would have returned NULL
+ and set errno to EOVERFLOW. */
+ return length;
+}