aboutsummaryrefslogtreecommitdiffstats
path: root/g10/trustdb.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
committerDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
commit909f6a0637b7111c294e5f6f37e4c3a0561bcd99 (patch)
treee1a4f448faaaee207c03d8813a15035c0e1c7f8b /g10/trustdb.c
parent* keyserver.c (keyserver_spawn): Include various pieces of information (diff)
downloadgnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.tar.gz
gnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.zip
* trustdb.c (validate_keys): Mask the ownertrust when building the list of
fully valid keys so that disabled keys are still counted in the web of trust. (get_ownertrust_with_min): Do the same for the minimum ownertrust calculation. * parse-packet.c (dump_sig_subpkt): Show the notation names for not-human-readable notations. Fix cosmetic off-by-one length counter. * options.skel: Add explantion and commented-out "no-mangle-dos-filenames". * mainproc.c (proc_encrypted): Make string translatable. * keyserver.c (keyserver_spawn): Quote ':', '%', and any 8-bit characters in the uid strings sent to the keyserver helper. * keyring.c (keyring_rebuild_cache): Lock the keyring while rebuilding the signature caches to prevent another gpg from tampering with the temporary copy. * keygen.c (keygen_set_std_prefs): Include AES192 and AES256 in default prefs. * keyedit.c (show_prefs): Make strings translatable. * keydb.c: Double the maximum number of keyrings to 40. * gpgv.c (main): Fix bug #113 - gpgv should accept the --ignore-time-conflict option. * g10.c (main): --openpgp disables --pgpX. Double the amount of secure memory to 32k (keys are getting bigger these days). * Makefile.am: Makefile.am: Use @CAPLIBS@ to link in -lcap if we are using capabilities.
Diffstat (limited to 'g10/trustdb.c')
-rw-r--r--g10/trustdb.c6
1 files changed, 4 insertions, 2 deletions
diff --git a/g10/trustdb.c b/g10/trustdb.c
index 7f38bbc86..3dc2ded07 100644
--- a/g10/trustdb.c
+++ b/g10/trustdb.c
@@ -638,7 +638,7 @@ get_ownertrust_with_min (PKT_public_key *pk)
{
unsigned int otrust,otrust_min;
- otrust = get_ownertrust (pk);
+ otrust = (get_ownertrust (pk) & TRUST_MASK);
otrust_min = get_min_ownertrust (pk);
if(otrust<otrust_min)
{
@@ -2004,7 +2004,8 @@ validate_keys (int interactive)
k->kid[0]=kid[0];
k->kid[1]=kid[1];
k->ownertrust =
- get_ownertrust (kar->keyblock->pkt->pkt.public_key);
+ (get_ownertrust (kar->keyblock->pkt->pkt.public_key)
+ & TRUST_MASK);
k->min_ownertrust =
get_min_ownertrust(kar->keyblock->pkt->pkt.public_key);
k->trust_depth=
@@ -2056,5 +2057,6 @@ validate_keys (int interactive)
do_sync ();
pending_check_trustdb = 0;
}
+
return rc;
}