aboutsummaryrefslogtreecommitdiffstats
path: root/g10/signal.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-12-18 22:23:49 +0000
committerDavid Shaw <[email protected]>2004-12-18 22:23:49 +0000
commit005b1d7960c0371207af42a4a060a6dd9cc72fac (patch)
treec39f1653def62376c7b684ed514142c25fee87cd /g10/signal.c
parent* configure.ac: Add a --with-ldap=DIR so people can add to the search (diff)
downloadgnupg-005b1d7960c0371207af42a4a060a6dd9cc72fac.tar.gz
gnupg-005b1d7960c0371207af42a4a060a6dd9cc72fac.zip
Readline fix to be robust against platforms where readline has its own
dependencies. We play guess-the-depedency for a while, and try termcap, curses, and ncurses.
Diffstat (limited to 'g10/signal.c')
-rw-r--r--g10/signal.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/g10/signal.c b/g10/signal.c
index 0f904ed97..7f91070f3 100644
--- a/g10/signal.c
+++ b/g10/signal.c
@@ -27,7 +27,7 @@
#include <string.h>
#include <errno.h>
#include <assert.h>
-#ifdef HAVE_READLINE_READLINE_H
+#ifdef HAVE_LIBREADLINE
#include <readline/readline.h>
#include <readline/history.h>
#endif
@@ -83,7 +83,7 @@ got_fatal_signal( int sig )
secmem_term();
-#if defined(HAVE_READLINE_READLINE_H) && defined(HAVE_LIBREADLINE)
+#ifdef HAVE_LIBREADLINE
rl_free_line_state ();
rl_cleanup_after_signal ();
#endif