aboutsummaryrefslogtreecommitdiffstats
path: root/g10/sign.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-10-31 05:39:02 +0000
committerDavid Shaw <[email protected]>2003-10-31 05:39:02 +0000
commit869c6bb7e455c91680bad8c2649bcfcdacfc4e7d (patch)
tree02e5d7eaacfbe5dfd6f5485b73c24f0332638877 /g10/sign.c
parent* cipher.h: Add COMPRESS_ALGO_BZIP2. (diff)
downloadgnupg-869c6bb7e455c91680bad8c2649bcfcdacfc4e7d.tar.gz
gnupg-869c6bb7e455c91680bad8c2649bcfcdacfc4e7d.zip
* misc.c (compress_algo_to_string, string_to_compress_algo,
check_compress_algo): Add bzip2. * compress.c (compress_filter): Make static to help force the use of push_compress_filter. Remove default algorithm setting since that is done in push_compress_filter now. * main.h: Use named algorithm. * filter.h, compress.c (push_compress_filter, push_compress_filter2): New. Figure out which is the appropriate compression filter to use, and push it into place. * compress.c (handle_compressed), encode.c (encode_simple, encode_crypt), sign.c (sign_file, sign_symencrypt_file), import.c (read_block), export.c (do_export): Use push_compress_filter instead of pushing the compression filter ourselves. * compress-bz2.c: New. Bzlib versions of the compression filter routines. * Makefile.am: Include compress-bz2.c if bz2lib is available.
Diffstat (limited to 'g10/sign.c')
-rw-r--r--g10/sign.c10
1 files changed, 2 insertions, 8 deletions
diff --git a/g10/sign.c b/g10/sign.c
index 3bfe602b2..b24e68f89 100644
--- a/g10/sign.c
+++ b/g10/sign.c
@@ -859,10 +859,7 @@ sign_file( STRLIST filenames, int detached, STRLIST locusr,
/* algo 0 means no compression */
if( compr_algo )
- {
- zfx.algo = compr_algo;
- iobuf_push_filter( out, compress_filter, &zfx );
- }
+ push_compress_filter(out,&zfx,compr_algo);
}
/* Write the one-pass signature packets if needed */
@@ -1181,10 +1178,7 @@ sign_symencrypt_file (const char *fname, STRLIST locusr)
/* Push the Zip filter */
if (opt.compress && default_compress_algo())
- {
- zfx.algo = default_compress_algo();
- iobuf_push_filter( out, compress_filter, &zfx );
- }
+ push_compress_filter(out,&zfx,opt.def_compress_algo);
/* Write the one-pass signature packets */
/*(current filters: zip - encrypt - armor)*/