aboutsummaryrefslogtreecommitdiffstats
path: root/g10/sig-check.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-26 13:21:12 +0000
committerDavid Shaw <[email protected]>2003-05-26 13:21:12 +0000
commitad9f6ae4b5e5a78d21d129fd249808842f49a226 (patch)
tree43654c3c724c6f686cf622bd31a24ac49db1d0a3 /g10/sig-check.c
parent* Makefile.am: Make use of AM_CFLAGS. (From wk on stable branch) (diff)
downloadgnupg-ad9f6ae4b5e5a78d21d129fd249808842f49a226.tar.gz
gnupg-ad9f6ae4b5e5a78d21d129fd249808842f49a226.zip
* getkey.c (premerge_public_with_secret): Made "no secret subkey for"
warning a verbose item and translatable. (From wk on stable branch) * sig-check.c (check_key_signature2): Made "no subkey for subkey binding packet" a verbose item instead of a !quiet one. There are too many garbled keys out in the wild. (From wk on stable branch) * filter.h: Remove const from WHAT. (From wk on stable branch) * progress.c (handle_progress): Store a copy of NAME. (progress_filter): Release WHAT, make sure not to print a NULL WHAT. (From wk on stable branch) * openfile.c (open_sigfile): Adjust free for new progress semantics. (From wk on stable branch) * plaintext.c (ask_for_detached_datafile): Don't dealloc pfx->WHAT. (From wk on stable branch) * seckey-cert.c (do_check): Issue the RSA_OR_IDEA status when the cipher algo is IDEA to make it easier to track down the problem. (From twoaday on stable branch)
Diffstat (limited to '')
-rw-r--r--g10/sig-check.c6
1 files changed, 3 insertions, 3 deletions
diff --git a/g10/sig-check.c b/g10/sig-check.c
index 47ee6a293..107cac5bb 100644
--- a/g10/sig-check.c
+++ b/g10/sig-check.c
@@ -574,9 +574,9 @@ check_key_signature2( KBNODE root, KBNODE node, PKT_public_key *check_pk,
md_close(md);
}
else {
- if (!opt.quiet)
- log_info ("key %08lX: no subkey for subkey "
- "binding signature\n",(ulong)keyid_from_pk(pk,NULL));
+ if (opt.verbose)
+ log_info ("key %08lX: no subkey for subkey binding packet\n",
+ (ulong)keyid_from_pk (pk, NULL));
rc = G10ERR_SIG_CLASS;
}
}