aboutsummaryrefslogtreecommitdiffstats
path: root/g10/progress.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-04-15 15:46:13 +0000
committerWerner Koch <[email protected]>2003-04-15 15:46:13 +0000
commitb394776a80e2e192eeaf5de82b2df8660298a091 (patch)
tree93e71726d93f4ca7c1289ddb70f19c067b51519d /g10/progress.c
parent* gpg.sgml: Document --enable-progress-filter. (diff)
downloadgnupg-b394776a80e2e192eeaf5de82b2df8660298a091.tar.gz
gnupg-b394776a80e2e192eeaf5de82b2df8660298a091.zip
* Makefile.am (AM_CFLAGS): Make use of AM_CFLAGS and AM_LDFLAGS.
* g10.c, options.h: New option --enable-progress-filter. * progress.c (handle_progress): Make use of it.
Diffstat (limited to 'g10/progress.c')
-rw-r--r--g10/progress.c104
1 files changed, 104 insertions, 0 deletions
diff --git a/g10/progress.c b/g10/progress.c
new file mode 100644
index 000000000..7313e29e5
--- /dev/null
+++ b/g10/progress.c
@@ -0,0 +1,104 @@
+/* progress.c
+ * Copyright (C) 2003 Free Software Foundation, Inc.
+ *
+ * This file is part of GnuPG.
+ *
+ * GnuPG is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License as published by
+ * the Free Software Foundation; either version 2 of the License, or
+ * (at your option) any later version.
+ *
+ * GnuPG is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ * GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+#include <config.h>
+#include <stdio.h>
+
+#include "iobuf.h"
+#include "filter.h"
+#include "status.h"
+#include "options.h"
+
+/****************
+ * The filter is used to report progress to the user.
+ */
+int
+progress_filter (void *opaque, int control,
+ IOBUF a, byte *buf, size_t *ret_len)
+{
+ int rc = 0;
+ progress_filter_context_t *pfx = opaque;
+
+ if (control == IOBUFCTRL_INIT)
+ {
+ char buffer[50];
+
+ pfx->last = 0;
+ pfx->offset = 0;
+ pfx->last_time = make_timestamp ();
+
+ sprintf (buffer, "%.20s ? %lu %lu", pfx->what, pfx->offset,
+ pfx->total);
+ write_status_text (STATUS_PROGRESS, buffer);
+ }
+ else if (control == IOBUFCTRL_UNDERFLOW)
+ {
+ u32 timestamp = make_timestamp ();
+ int len = iobuf_read (a, buf, *ret_len);
+
+ if (len >= 0)
+ {
+ pfx->offset += len;
+ *ret_len = len;
+ }
+ else
+ {
+ *ret_len = 0;
+ rc = -1;
+ }
+ if ((len == -1 && pfx->offset != pfx->last)
+ || timestamp - pfx->last_time > 0)
+ {
+ char buffer[50];
+
+ sprintf (buffer, "%.20s ? %lu %lu", pfx->what, pfx->offset,
+ pfx->total);
+ write_status_text (STATUS_PROGRESS, buffer);
+
+ pfx->last = pfx->offset;
+ pfx->last_time = timestamp;
+ }
+ }
+ else if (control == IOBUFCTRL_DESC)
+ *(char**)buf = "progress_filter";
+ return rc;
+}
+
+void
+handle_progress (progress_filter_context_t *pfx, IOBUF inp, char *name)
+{
+ off_t filesize = 0;
+
+ if (!opt.enable_progress_filter)
+ return;
+
+ if (!is_status_enabled ())
+ return;
+
+ if (name)
+ filesize = iobuf_get_filelength (inp);
+ else if (opt.set_filesize)
+ filesize = opt.set_filesize;
+
+ /* register the progress filter */
+ pfx->what = name ? name : "stdin";
+ pfx->total = filesize;
+ iobuf_push_filter (inp, progress_filter, pfx);
+}