aboutsummaryrefslogtreecommitdiffstats
path: root/g10/plaintext.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-26 13:21:12 +0000
committerDavid Shaw <[email protected]>2003-05-26 13:21:12 +0000
commitad9f6ae4b5e5a78d21d129fd249808842f49a226 (patch)
tree43654c3c724c6f686cf622bd31a24ac49db1d0a3 /g10/plaintext.c
parent* Makefile.am: Make use of AM_CFLAGS. (From wk on stable branch) (diff)
downloadgnupg-ad9f6ae4b5e5a78d21d129fd249808842f49a226.tar.gz
gnupg-ad9f6ae4b5e5a78d21d129fd249808842f49a226.zip
* getkey.c (premerge_public_with_secret): Made "no secret subkey for"
warning a verbose item and translatable. (From wk on stable branch) * sig-check.c (check_key_signature2): Made "no subkey for subkey binding packet" a verbose item instead of a !quiet one. There are too many garbled keys out in the wild. (From wk on stable branch) * filter.h: Remove const from WHAT. (From wk on stable branch) * progress.c (handle_progress): Store a copy of NAME. (progress_filter): Release WHAT, make sure not to print a NULL WHAT. (From wk on stable branch) * openfile.c (open_sigfile): Adjust free for new progress semantics. (From wk on stable branch) * plaintext.c (ask_for_detached_datafile): Don't dealloc pfx->WHAT. (From wk on stable branch) * seckey-cert.c (do_check): Issue the RSA_OR_IDEA status when the cipher algo is IDEA to make it easier to track down the problem. (From twoaday on stable branch)
Diffstat (limited to '')
-rw-r--r--g10/plaintext.c6
1 files changed, 0 insertions, 6 deletions
diff --git a/g10/plaintext.c b/g10/plaintext.c
index 3183785b4..89043026c 100644
--- a/g10/plaintext.c
+++ b/g10/plaintext.c
@@ -358,14 +358,11 @@ ask_for_detached_datafile( MD_HANDLE md, MD_HANDLE md2,
const char *inname, int textmode )
{
progress_filter_context_t pfx;
- int dealloc_pfx_name = 1;
char *answer = NULL;
IOBUF fp;
int rc = 0;
fp = open_sigfile( inname, &pfx ); /* open default file */
- if (!fp)
- dealloc_pfx_name = 0;
if( !fp && !opt.batch ) {
int any=0;
@@ -400,8 +397,6 @@ ask_for_detached_datafile( MD_HANDLE md, MD_HANDLE md2,
}
do_hash( md, md2, fp, textmode );
iobuf_close(fp);
- if (dealloc_pfx_name)
- m_free ((void *)pfx.what);
leave:
m_free(answer);
@@ -428,7 +423,6 @@ hash_datafiles( MD_HANDLE md, MD_HANDLE md2, STRLIST files,
if( fp ) {
do_hash( md, md2, fp, textmode );
iobuf_close(fp);
- m_free ((void *)pfx.what);
return 0;
}
log_error (_("no signed data\n"));