aboutsummaryrefslogtreecommitdiffstats
path: root/g10/pkclist.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-04-23 21:18:39 +0000
committerDavid Shaw <[email protected]>2003-04-23 21:18:39 +0000
commit874214d0a0a0754d8fc48e57b066c778d3869e44 (patch)
treec2176ae3e2181f4069acf0652513e18261f4493b /g10/pkclist.c
parent* Makefile.am, options.in: Rename options.in to options since it no longer (diff)
downloadgnupg-874214d0a0a0754d8fc48e57b066c778d3869e44.tar.gz
gnupg-874214d0a0a0754d8fc48e57b066c778d3869e44.zip
* import.c (import_revoke_cert): Remove ultimate trust when revoking an
ultimately trusted key. * keyedit.c (sign_uids): Allow replacing expired signatures. Allow duplicate signatures with --expert. * pkclist.c (check_signatures_trust): Don't display a null fingerprint when checking a signature with --always-trust enabled. * filter.h (progress_filter_context_t), progress.c (handle_progress), plaintext.c (ask_for_detached_datafile, hash_datafiles): Fix compiler warnings. Make "what" constant. * build-packet.c (do_plaintext): Do not create invalid literal packets with >255-byte names.
Diffstat (limited to 'g10/pkclist.c')
-rw-r--r--g10/pkclist.c20
1 files changed, 10 insertions, 10 deletions
diff --git a/g10/pkclist.c b/g10/pkclist.c
index e3f12417e..99f98b336 100644
--- a/g10/pkclist.c
+++ b/g10/pkclist.c
@@ -1,6 +1,6 @@
/* pkclist.c
- * Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003
- * Free Software Foundation, Inc.
+ * Copyright (C) 1998, 1999, 2000, 2001, 2002
+ * 2003 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -591,6 +591,14 @@ check_signatures_trust( PKT_signature *sig )
unsigned int trustlevel;
int rc=0;
+ rc = get_pubkey( pk, sig->keyid );
+ if (rc)
+ { /* this should not happen */
+ log_error("Ooops; the key vanished - can't check the trust\n");
+ rc = G10ERR_NO_PUBKEY;
+ goto leave;
+ }
+
if ( opt.trust_model==TM_ALWAYS )
{
if( !opt.quiet )
@@ -600,14 +608,6 @@ check_signatures_trust( PKT_signature *sig )
goto leave;
}
- rc = get_pubkey( pk, sig->keyid );
- if (rc)
- { /* this should not happen */
- log_error("Ooops; the key vanished - can't check the trust\n");
- rc = G10ERR_NO_PUBKEY;
- goto leave;
- }
-
trustlevel = get_validity (pk, NULL);
if ( (trustlevel & TRUST_FLAG_REVOKED) )