aboutsummaryrefslogtreecommitdiffstats
path: root/g10/passphrase.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2004-04-06 10:01:04 +0000
committerWerner Koch <[email protected]>2004-04-06 10:01:04 +0000
commitd84d632583c1c61180d40ce9b91f185160ab02d6 (patch)
tree95f50ee6802e523b69a99d7bd49405e715923e55 /g10/passphrase.c
parentAdd STATUS_NEWSIG (diff)
downloadgnupg-d84d632583c1c61180d40ce9b91f185160ab02d6.tar.gz
gnupg-d84d632583c1c61180d40ce9b91f185160ab02d6.zip
* configure.ac: Require libgcrypt 1.1.94.
Introduce PACKAGE_GT and set it to gnupg2. * gpg-agent.c (main): Use new libgcrypt thread library register scheme. * Makevars (DOMAIN): Init from PACKAGE_GT
Diffstat (limited to 'g10/passphrase.c')
-rw-r--r--g10/passphrase.c12
1 files changed, 6 insertions, 6 deletions
diff --git a/g10/passphrase.c b/g10/passphrase.c
index 27ffcad97..986070a16 100644
--- a/g10/passphrase.c
+++ b/g10/passphrase.c
@@ -649,8 +649,8 @@ agent_get_passphrase ( u32 *keyid, int mode, const char *tryagain_text,
}
#ifdef ENABLE_NLS
- /* The Assuan agent protol requires us to trasnmit utf-8 strings */
- orig_codeset = bind_textdomain_codeset (PACKAGE, NULL);
+ /* The Assuan agent protocol requires us to transmit utf-8 strings */
+ orig_codeset = bind_textdomain_codeset (PACKAGE_GT, NULL);
#ifdef HAVE_LANGINFO_CODESET
if (!orig_codeset)
orig_codeset = nl_langinfo (CODESET);
@@ -658,7 +658,7 @@ agent_get_passphrase ( u32 *keyid, int mode, const char *tryagain_text,
if (orig_codeset)
{ /* We only switch when we are able to restore the codeset later. */
orig_codeset = xstrdup (orig_codeset);
- if (!bind_textdomain_codeset (PACKAGE, "utf-8"))
+ if (!bind_textdomain_codeset (PACKAGE_GT, "utf-8"))
orig_codeset = NULL;
}
#endif
@@ -765,7 +765,7 @@ agent_get_passphrase ( u32 *keyid, int mode, const char *tryagain_text,
free_public_key( pk );
#ifdef ENABLE_NLS
if (orig_codeset)
- bind_textdomain_codeset (PACKAGE, orig_codeset);
+ bind_textdomain_codeset (PACKAGE_GT, orig_codeset);
#endif
xfree (orig_codeset);
return pw;
@@ -857,7 +857,7 @@ agent_get_passphrase ( u32 *keyid, int mode, const char *tryagain_text,
free_public_key( pk );
#ifdef ENABLE_NLS
if (orig_codeset)
- bind_textdomain_codeset (PACKAGE, orig_codeset);
+ bind_textdomain_codeset (PACKAGE_GT, orig_codeset);
#endif
xfree (orig_codeset);
return pw;
@@ -880,7 +880,7 @@ agent_get_passphrase ( u32 *keyid, int mode, const char *tryagain_text,
failure:
#ifdef ENABLE_NLS
if (orig_codeset)
- bind_textdomain_codeset (PACKAGE, orig_codeset);
+ bind_textdomain_codeset (PACKAGE_GT, orig_codeset);
#endif
xfree (atext);
if ( fd != -1 )