aboutsummaryrefslogtreecommitdiffstats
path: root/g10/parse-packet.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
committerDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
commit909f6a0637b7111c294e5f6f37e4c3a0561bcd99 (patch)
treee1a4f448faaaee207c03d8813a15035c0e1c7f8b /g10/parse-packet.c
parent* keyserver.c (keyserver_spawn): Include various pieces of information (diff)
downloadgnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.tar.gz
gnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.zip
* trustdb.c (validate_keys): Mask the ownertrust when building the list of
fully valid keys so that disabled keys are still counted in the web of trust. (get_ownertrust_with_min): Do the same for the minimum ownertrust calculation. * parse-packet.c (dump_sig_subpkt): Show the notation names for not-human-readable notations. Fix cosmetic off-by-one length counter. * options.skel: Add explantion and commented-out "no-mangle-dos-filenames". * mainproc.c (proc_encrypted): Make string translatable. * keyserver.c (keyserver_spawn): Quote ':', '%', and any 8-bit characters in the uid strings sent to the keyserver helper. * keyring.c (keyring_rebuild_cache): Lock the keyring while rebuilding the signature caches to prevent another gpg from tampering with the temporary copy. * keygen.c (keygen_set_std_prefs): Include AES192 and AES256 in default prefs. * keyedit.c (show_prefs): Make strings translatable. * keydb.c: Double the maximum number of keyrings to 40. * gpgv.c (main): Fix bug #113 - gpgv should accept the --ignore-time-conflict option. * g10.c (main): --openpgp disables --pgpX. Double the amount of secure memory to 32k (keys are getting bigger these days). * Makefile.am: Makefile.am: Use @CAPLIBS@ to link in -lcap if we are using capabilities.
Diffstat (limited to 'g10/parse-packet.c')
-rw-r--r--g10/parse-packet.c12
1 files changed, 7 insertions, 5 deletions
diff --git a/g10/parse-packet.c b/g10/parse-packet.c
index d270ece7d..7e390ae55 100644
--- a/g10/parse-packet.c
+++ b/g10/parse-packet.c
@@ -752,12 +752,12 @@ dump_sig_subpkt( int hashed, int type, int critical,
type, (unsigned)length );
}
+ buffer++;
+ length--;
printf("\t%s%ssubpkt %d len %u (", /*)*/
critical ? "critical ":"",
hashed ? "hashed ":"", type, (unsigned)length );
- buffer++;
- length--;
if( length > buflen ) {
printf("too short: buffer is only %u)\n", (unsigned)buflen );
return;
@@ -823,8 +823,6 @@ dump_sig_subpkt( int hashed, int type, int critical,
fputs("notation: ", stdout );
if( length < 8 )
p = "[too short]";
- else if( !(*buffer & 0x80) )
- p = "[not human readable]";
else {
const byte *s = buffer;
size_t n1, n2;
@@ -837,7 +835,11 @@ dump_sig_subpkt( int hashed, int type, int critical,
else {
print_string( stdout, s, n1, ')' );
putc( '=', stdout );
- print_string( stdout, s+n1, n2, ')' );
+
+ if( *buffer & 0x80 )
+ print_string( stdout, s+n1, n2, ')' );
+ else
+ p = "[not human readable]";
}
}
}