aboutsummaryrefslogtreecommitdiffstats
path: root/g10/packet.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-05-31 04:06:06 +0000
committerDavid Shaw <[email protected]>2003-05-31 04:06:06 +0000
commit9390fe676bbd619f37d147c86651f6f30a67fb9b (patch)
tree3f70cf87ffdc4f4dba5493bd22a175de32f528d6 /g10/packet.h
parent* gpgkeys_hkp.c, gpgkeys_ldap.c: #include <getopt.h> if it is available. (diff)
downloadgnupg-9390fe676bbd619f37d147c86651f6f30a67fb9b.tar.gz
gnupg-9390fe676bbd619f37d147c86651f6f30a67fb9b.zip
* keylist.c (list_one): Don't show the keyring filename when in
--with-colons mode. Actually translate "Keyring" string. * mainproc.c (proc_tree): We can't currently handle multiple signatures of different classes or digests (we'd pretty much have to run a different hash context for each), but if they are all the same, make an exception. This is Debian bug #194292. * sig-check.c (check_key_signature2): Make string translatable. * packet.h, getkey.c (fixup_uidnode): Mark real primary uids differently than assumed primaries. * keyedit.c (no_primary_warning): Use the differently marked primaries here in a new function to warn when an --edit-key command might rearrange the self-sig dates enough to change which uid is primary. (menu_expire, menu_set_preferences): Use no_primary_warning() here. * Makefile.am: Use @DLLIBS@ for -ldl.
Diffstat (limited to 'g10/packet.h')
-rw-r--r--g10/packet.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/packet.h b/g10/packet.h
index 290afac68..c391c53a4 100644
--- a/g10/packet.h
+++ b/g10/packet.h
@@ -173,7 +173,7 @@ typedef struct {
u32 help_key_expire;
int help_full_count;
int help_marginal_count;
- int is_primary;
+ int is_primary; /* 2 if set via the primary flag, 1 if calculated */
int is_revoked;
int is_expired;
u32 expiredate; /* expires at this date or 0 if not at all */