aboutsummaryrefslogtreecommitdiffstats
path: root/g10/packet.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
committerDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
commit06442ab0da6c119fb18ee8a19984ebac89e1fc75 (patch)
tree8e4dc3194719bcced63dfe52be4def9c9c3a5685 /g10/packet.h
parent* Makefile.am: Add sc-copykeys program. (diff)
downloadgnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.tar.gz
gnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.zip
* packet.h, main.h, sig-check.c (signature_check2, check_key_signature2,
do_check): If ret_pk is set, fill in the pk used to verify the signature. Change all callers in getkey.c, mainproc.c, and sig-check.c. * keylist.c (list_keyblock_colon): Use the ret_pk from above to put the fingerprint of the signing key in "sig" records during a --with-colons --check-sigs. This requires --no-sig-cache as well since we don't cache fingerprints.
Diffstat (limited to '')
-rw-r--r--g10/packet.h4
1 files changed, 2 insertions, 2 deletions
diff --git a/g10/packet.h b/g10/packet.h
index c391c53a4..516c93a44 100644
--- a/g10/packet.h
+++ b/g10/packet.h
@@ -460,8 +460,8 @@ int cmp_user_ids( PKT_user_id *a, PKT_user_id *b );
/*-- sig-check.c --*/
int signature_check( PKT_signature *sig, MD_HANDLE digest );
-int signature_check2( PKT_signature *sig, MD_HANDLE digest,
- u32 *r_expiredate, int *r_expired );
+int signature_check2( PKT_signature *sig, MD_HANDLE digest, u32 *r_expiredate,
+ int *r_expired, PKT_public_key *ret_pk );
/*-- seckey-cert.c --*/
int is_secret_key_protected( PKT_secret_key *sk );