aboutsummaryrefslogtreecommitdiffstats
path: root/g10/options.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-10-13 15:34:52 +0000
committerDavid Shaw <[email protected]>2004-10-13 15:34:52 +0000
commit9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce (patch)
treeaed46514ac8908373174ae052b2789a188ca6fbb /g10/options.h
parent* configure.ac: Actually name the option --disable-finger and not (diff)
downloadgnupg-9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce.tar.gz
gnupg-9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce.zip
* pkclist.c (do_edit_ownertrust): Different prompt when we're using direct
trust since the meaning is different. * keyedit.c (trustsig_prompt): Change the strings to match the ones in pkclist.c:do_edit_ownertrust to make translation easier. * trustdb.c (trust_model_string, get_validity): Add direct trust model which applies to the key as a whole and not per-uid. * options.h, g10.c (parse_trust_model): New. (main): Call it from here to do string-to-trust-model.
Diffstat (limited to 'g10/options.h')
-rw-r--r--g10/options.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/options.h b/g10/options.h
index f952eeab4..720b70a5c 100644
--- a/g10/options.h
+++ b/g10/options.h
@@ -100,7 +100,7 @@ struct
we started storing the trust model inside the trustdb. */
enum
{
- TM_CLASSIC=0, TM_PGP=1, TM_EXTERNAL=2, TM_ALWAYS, TM_AUTO
+ TM_CLASSIC=0, TM_PGP=1, TM_EXTERNAL=2, TM_ALWAYS, TM_DIRECT, TM_AUTO
} trust_model;
int force_ownertrust;
enum