aboutsummaryrefslogtreecommitdiffstats
path: root/g10/options.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-06-14 03:55:19 +0000
committerDavid Shaw <[email protected]>2005-06-14 03:55:19 +0000
commit07e9d532b1ea3a196dfec192960f9ef811654571 (patch)
tree5726b0160d2d7e501f3cc712ca29944a429b91eb /g10/options.h
parent* configure.ac: Add check for no-pointer-sign warning keyword, and (diff)
downloadgnupg-07e9d532b1ea3a196dfec192960f9ef811654571.tar.gz
gnupg-07e9d532b1ea3a196dfec192960f9ef811654571.zip
* keygen.c (save_unprotected_key_to_card): Fix gcc4 warning.
* options.h, import.c (parse_import_options, import_one): Add import-clean-uids option to automatically compact unusable uids when importing. Like import-clean-sigs, this may nodify the local keyring. * trustdb.c (clean_uids_from_key): Only allow selfsigs to be a candidate for re-inclusion.
Diffstat (limited to 'g10/options.h')
-rw-r--r--g10/options.h1
1 files changed, 1 insertions, 0 deletions
diff --git a/g10/options.h b/g10/options.h
index f0b6f199f..8635d9b93 100644
--- a/g10/options.h
+++ b/g10/options.h
@@ -252,6 +252,7 @@ struct {
#define IMPORT_SK2PK (1<<3)
#define IMPORT_MERGE_ONLY (1<<4)
#define IMPORT_CLEAN_SIGS (1<<5)
+#define IMPORT_CLEAN_UIDS (1<<6)
#define EXPORT_LOCAL_SIGS (1<<0)
#define EXPORT_ATTRIBUTES (1<<1)