aboutsummaryrefslogtreecommitdiffstats
path: root/g10/options.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
committerDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
commit7c9855aaa2819c6774ba164f9991e9972556aa3f (patch)
tree038fbcf02207b726823576490906bac8a129f60e /g10/options.h
parent* configure.ac: Define SAFE_VERSION so that RISCOS can override it and (diff)
downloadgnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.tar.gz
gnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.zip
* options.h, g10.c (main), keylist.c (list_keyblock_print): Add
"show-validity" and "show-long-keyid" list-options. * gpgv.c (get_validity, trust_value_to_string): Stubs. * g10.c (main): Use SAFE_VERSION instead of VERSION in the version-specific gpg.conf file so it can be overridden on RISCOS.
Diffstat (limited to '')
-rw-r--r--g10/options.h10
1 files changed, 6 insertions, 4 deletions
diff --git a/g10/options.h b/g10/options.h
index 9c62a959b..1a70277dc 100644
--- a/g10/options.h
+++ b/g10/options.h
@@ -227,10 +227,12 @@ struct {
#define EXPORT_INCLUDE_ATTRIBUTES 4
#define EXPORT_INCLUDE_SENSITIVE_REVKEYS 8
-#define LIST_SHOW_PHOTOS 1
-#define LIST_SHOW_POLICY 2
-#define LIST_SHOW_NOTATION 4
-#define LIST_SHOW_KEYRING 8
+#define LIST_SHOW_PHOTOS 1
+#define LIST_SHOW_POLICY 2
+#define LIST_SHOW_NOTATION 4
+#define LIST_SHOW_KEYRING 8
+#define LIST_SHOW_VALIDITY 16
+#define LIST_SHOW_LONG_KEYID 32
#define VERIFY_SHOW_PHOTOS 1
#define VERIFY_SHOW_POLICY 2