aboutsummaryrefslogtreecommitdiffstats
path: root/g10/misc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-01 18:16:55 +0000
committerDavid Shaw <[email protected]>2006-03-01 18:16:55 +0000
commit78904c691c1e573322a2d5eff06c7e38553ebd36 (patch)
tree8e105347e4dd616cb0a07ab0a8bce02f46e67ff2 /g10/misc.c
parent* configure.ac: Fix accidental enabling of SHA-384/512. Noted by Nelson (diff)
downloadgnupg-78904c691c1e573322a2d5eff06c7e38553ebd36.tar.gz
gnupg-78904c691c1e573322a2d5eff06c7e38553ebd36.zip
* getkey.c (parse_auto_key_locate): Error if the user selects "cert" or
"pka" when those features are disabled. * misc.c (has_invalid_email_chars): Fix some C syntax that broke the compilers on SGI IRIX MIPS and Compaq/DEC OSF/1 Alpha. Noted by Nelson H. F. Beebe.
Diffstat (limited to 'g10/misc.c')
-rw-r--r--g10/misc.c7
1 files changed, 2 insertions, 5 deletions
diff --git a/g10/misc.c b/g10/misc.c
index b0fe82560..74d05cb56 100644
--- a/g10/misc.c
+++ b/g10/misc.c
@@ -1081,15 +1081,12 @@ unescape_percent_string (const unsigned char *s)
}
-
-
int
has_invalid_email_chars (const char *s)
{
int at_seen=0;
- static char valid_chars[] = ("01234567890_-."
- "abcdefghijklmnopqrstuvwxyz"
- "ABCDEFGHIJKLMNOPQRSTUVWXYZ");
+ const char *valid_chars=
+ "01234567890_-.abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ";
for ( ; *s; s++ )
{