aboutsummaryrefslogtreecommitdiffstats
path: root/g10/misc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-22 13:00:18 +0000
committerDavid Shaw <[email protected]>2003-02-22 13:00:18 +0000
commit6f41d068418ca9a9ff7541d5fafc1fcdb20804cf (patch)
tree4f508a2ed6846271970e2ee48cd0bcb77db6c087 /g10/misc.c
parent* configure.ac: Add --disable-xxx options for CAST5, BLOWFISH, AES (all), (diff)
downloadgnupg-6f41d068418ca9a9ff7541d5fafc1fcdb20804cf.tar.gz
gnupg-6f41d068418ca9a9ff7541d5fafc1fcdb20804cf.zip
* g10.c (main): Accept "s1" in addition to "idea" to match the other
ciphers. * main.h, misc.c (idea_cipher_warn): We don't need this if IDEA has been disabled.
Diffstat (limited to 'g10/misc.c')
-rw-r--r--g10/misc.c2
1 files changed, 2 insertions, 0 deletions
diff --git a/g10/misc.c b/g10/misc.c
index c5506948a..08bbdc6fe 100644
--- a/g10/misc.c
+++ b/g10/misc.c
@@ -289,6 +289,7 @@ openpgp_md_test_algo( int algo )
return check_digest_algo(algo);
}
+#ifdef USE_IDEA
/* Special warning for the IDEA cipher */
void
idea_cipher_warn(int show)
@@ -303,6 +304,7 @@ idea_cipher_warn(int show)
warned=1;
}
}
+#endif
/* Expand %-strings. Returns a string which must be m_freed. Returns
NULL if the string cannot be expanded (too large). */