aboutsummaryrefslogtreecommitdiffstats
path: root/g10/misc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-01-22 21:40:20 +0000
committerDavid Shaw <[email protected]>2006-01-22 21:40:20 +0000
commit4ff7d09040363aefc1f5ab7fe48dd5f34f084164 (patch)
treeec2e073993ee51d9cc932ab259f4f0a426f422a6 /g10/misc.c
parent* configure.ac: Add define for EXEEXT so we can find keyserver helpers (diff)
downloadgnupg-4ff7d09040363aefc1f5ab7fe48dd5f34f084164.tar.gz
gnupg-4ff7d09040363aefc1f5ab7fe48dd5f34f084164.zip
* keyserver.c (keyserver_spawn): Include the EXEEXT so we can find
keyserver helpers on systems that use extensions. * misc.c (path_access) [HAVE_DRIVE_LETTERS]: Do the right thing with drive letter systems.
Diffstat (limited to 'g10/misc.c')
-rw-r--r--g10/misc.c10
1 files changed, 9 insertions, 1 deletions
diff --git a/g10/misc.c b/g10/misc.c
index c5b97740c..b0fe82560 100644
--- a/g10/misc.c
+++ b/g10/misc.c
@@ -1251,7 +1251,15 @@ path_access(const char *file,int mode)
envpath=getenv("PATH");
- if(file[0]=='/' || !envpath)
+ if(!envpath
+#ifdef HAVE_DRIVE_LETTERS
+ || (((file[0]>='A' && file[0]<='Z')
+ || (file[0]>='a' && file[0]<='z'))
+ && file[1]==':')
+#else
+ || file[0]=='/'
+#endif
+ )
return access(file,mode);
else
{