aboutsummaryrefslogtreecommitdiffstats
path: root/g10/mainproc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-10-07 22:19:11 +0000
committerDavid Shaw <[email protected]>2002-10-07 22:19:11 +0000
commite4f5b9b4c2446c0c766bda018ef7e6d1d669985f (patch)
tree5dda6b651ab1db17c5d55b3f3c1253ebc84fa797 /g10/mainproc.c
parent* configure.ac: OpenLDAP 2.0.27 changed the dependencies again. Add a (diff)
downloadgnupg-e4f5b9b4c2446c0c766bda018ef7e6d1d669985f.tar.gz
gnupg-e4f5b9b4c2446c0c766bda018ef7e6d1d669985f.zip
* import.c (import_keys_internal): Missed one s/inp/inp2/.
* keylist.c (print_capabilities): Properly indicate per-key capabilities of sign&encrypt primary keys that have secret-parts-missing (i.e. no capabilities at all) * mainproc.c (symkey_decrypt_sesskey): Fix compiler warning.
Diffstat (limited to 'g10/mainproc.c')
-rw-r--r--g10/mainproc.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/g10/mainproc.c b/g10/mainproc.c
index 896120e86..f9be17600 100644
--- a/g10/mainproc.c
+++ b/g10/mainproc.c
@@ -245,7 +245,8 @@ symkey_decrypt_sesskey( DEK *dek, byte *sesskey, size_t slen )
int n;
if ( slen < 17 || slen > 33 ) {
- log_error ( _("weird size for an encrypted session key (%d)\n"), slen);
+ log_error ( _("weird size for an encrypted session key (%d)\n"),
+ (int)slen);
return;
}
hd = cipher_open( dek->algo, CIPHER_MODE_CFB, 1 );