aboutsummaryrefslogtreecommitdiffstats
path: root/g10/mainproc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-07-30 16:48:21 +0000
committerDavid Shaw <[email protected]>2002-07-30 16:48:21 +0000
commit928dba9e708cf8955e32371b762fd47ea251ee3d (patch)
treecfd73a79b67490348d414c94781e44c6e6d8b836 /g10/mainproc.c
parent* README, configure.ac: --with-exec-path is now clarified into (diff)
downloadgnupg-928dba9e708cf8955e32371b762fd47ea251ee3d.tar.gz
gnupg-928dba9e708cf8955e32371b762fd47ea251ee3d.zip
* options.h, g10.c (main), mainproc.c (proc_encrypted): Return a
decryption failed error if a MDC does not verify. Warn if a MDC is not present (can disable via --no-mdc-warning). * exec.c (exec_write), g10.c (main), keyserver.c (keyserver_spawn): Use new DISABLE_KEYSERVER_PATH rather than FIXED_EXEC_PATH.
Diffstat (limited to 'g10/mainproc.c')
-rw-r--r--g10/mainproc.c3
1 files changed, 3 insertions, 0 deletions
diff --git a/g10/mainproc.c b/g10/mainproc.c
index f5c1dfe9a..2004da1c7 100644
--- a/g10/mainproc.c
+++ b/g10/mainproc.c
@@ -498,10 +498,13 @@ proc_encrypted( CTX c, PACKET *pkt )
log_info(_("decryption okay\n"));
if( pkt->pkt.encrypted->mdc_method )
write_status( STATUS_GOODMDC );
+ else if(!opt.no_mdc_warn)
+ log_info ("WARNING: message was not integrity protected\n");
}
else if( result == G10ERR_BAD_SIGN ) {
log_error(_("WARNING: encrypted message has been manipulated!\n"));
write_status( STATUS_BADMDC );
+ write_status( STATUS_DECRYPTION_FAILED );
}
else {
write_status( STATUS_DECRYPTION_FAILED );