aboutsummaryrefslogtreecommitdiffstats
path: root/g10/mainproc.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
committerDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
commit06442ab0da6c119fb18ee8a19984ebac89e1fc75 (patch)
tree8e4dc3194719bcced63dfe52be4def9c9c3a5685 /g10/mainproc.c
parent* Makefile.am: Add sc-copykeys program. (diff)
downloadgnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.tar.gz
gnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.zip
* packet.h, main.h, sig-check.c (signature_check2, check_key_signature2,
do_check): If ret_pk is set, fill in the pk used to verify the signature. Change all callers in getkey.c, mainproc.c, and sig-check.c. * keylist.c (list_keyblock_colon): Use the ret_pk from above to put the fingerprint of the signing key in "sig" records during a --with-colons --check-sigs. This requires --no-sig-cache as well since we don't cache fingerprints.
Diffstat (limited to 'g10/mainproc.c')
-rw-r--r--g10/mainproc.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/g10/mainproc.c b/g10/mainproc.c
index 99cc4f11b..0bd1a56eb 100644
--- a/g10/mainproc.c
+++ b/g10/mainproc.c
@@ -722,9 +722,9 @@ do_check_sig( CTX c, KBNODE node, int *is_selfsig, int *is_expkey )
}
else
return G10ERR_SIG_CLASS;
- rc = signature_check2( sig, md, &dummy, is_expkey );
+ rc = signature_check2( sig, md, &dummy, is_expkey, NULL );
if( rc == G10ERR_BAD_SIGN && md2 )
- rc = signature_check2( sig, md2, &dummy, is_expkey );
+ rc = signature_check2( sig, md2, &dummy, is_expkey, NULL );
md_close(md);
md_close(md2);