aboutsummaryrefslogtreecommitdiffstats
path: root/g10/main.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-08-07 15:53:15 +0000
committerDavid Shaw <[email protected]>2002-08-07 15:53:15 +0000
commitfee7e35baefb742d504c979b3cf0aeaeb5a87b60 (patch)
tree23112bb915861942dacce217c2474486d76be48d /g10/main.h
parent* configure.ac: If the static IDEA cipher is present, disable dynamic (diff)
downloadgnupg-fee7e35baefb742d504c979b3cf0aeaeb5a87b60.tar.gz
gnupg-fee7e35baefb742d504c979b3cf0aeaeb5a87b60.zip
* keyedit.c (menu_revsig): Properly show a uid is revoked without
restarting gpg. This is Debian bug 124219, though their supplied patch will not do the right thing. * main.h, tdbio.c (tdbio_set_dbname), misc.c (removed check_permissions), keydb.c (keydb_add_resource), g10.c (main, check_permissions): Significant reworking of the permission check mechanism. The new behavior is to check everything in the homedir by checking the homedir itself. If the user wants to put (possibly shared) keyrings outside the homedir, they are not checked. The options file and any extension files are checked wherever they are, as well as their enclosing directories. This is Debian bug 147760.
Diffstat (limited to 'g10/main.h')
-rw-r--r--g10/main.h1
1 files changed, 0 insertions, 1 deletions
diff --git a/g10/main.h b/g10/main.h
index 9edccaf21..09d4a93d8 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -71,7 +71,6 @@ int openpgp_cipher_test_algo( int algo );
int openpgp_pk_test_algo( int algo, unsigned int usage_flags );
int openpgp_pk_algo_usage ( int algo );
int openpgp_md_test_algo( int algo );
-int check_permissions(const char *path,int extension,int checkonly);
void idea_cipher_warn( int show );
struct expando_args