aboutsummaryrefslogtreecommitdiffstats
path: root/g10/main.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2005-08-21 20:58:46 +0000
committerDavid Shaw <[email protected]>2005-08-21 20:58:46 +0000
commit24adfe678d1e0b26186d65cf4be48b9ed2f215e7 (patch)
tree68bb3d0f4d0d4c64972a843b178cb34ffb446b86 /g10/main.h
parent* exec.h, exec.c (make_tempdir, expand_args, exec_write, exec_read): (diff)
downloadgnupg-24adfe678d1e0b26186d65cf4be48b9ed2f215e7.tar.gz
gnupg-24adfe678d1e0b26186d65cf4be48b9ed2f215e7.zip
* Makefile.am: No need to link with curl any longer.
* main.h, misc.c (path_access): New. Same as access() but does a PATH search like execlp. * keyserver.c (curl_can_handle): Removed. Replaced by... (curl_cant_handle): We are now relying on curl as the handler of last resort. This is necessary because PGP LDAP and curl LDAP are apples and oranges. (keyserver_typemap): Only test for ldap and ldaps. (keyserver_spawn): If a given handler is unusable (as determined by path_access()) then try gpgkeys_curl.
Diffstat (limited to 'g10/main.h')
-rw-r--r--g10/main.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/main.h b/g10/main.h
index d3c8083dc..e53f73cb5 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -129,7 +129,7 @@ int has_invalid_email_chars (const char *s);
int is_valid_mailbox (const char *name);
char *default_homedir (void);
const char *get_libexecdir (void);
-
+int path_access(const char *file,int mode);
/*-- helptext.c --*/
void display_online_help( const char *keyword );