aboutsummaryrefslogtreecommitdiffstats
path: root/g10/main.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-26 17:11:24 +0000
committerDavid Shaw <[email protected]>2003-02-26 17:11:24 +0000
commitcb2167a306bf7ea2b8284dc654ed2f3fd8d40c06 (patch)
tree0a62ef5f7a8c37782e80858e45dcdb825cbce793 /g10/main.h
parent* distfiles, gnupg.spec.in: convert-from-106 is in the tools directory (diff)
downloadgnupg-cb2167a306bf7ea2b8284dc654ed2f3fd8d40c06.tar.gz
gnupg-cb2167a306bf7ea2b8284dc654ed2f3fd8d40c06.zip
* keyserver.c (keyserver_spawn): Include various pieces of information
about the key in the data sent to the keyserver helper. This allows the helper to use it in instructing a remote server which may not have any actual OpenPGP smarts in parsing keys. * main.h, export.c (export_pubkeys_stream, do_export_stream): Add ability to return only the first match in an exported keyblock for keyserver usage. This should be replaced at some point with a more flexible solution where each key can be armored seperately.
Diffstat (limited to '')
-rw-r--r--g10/main.h3
1 files changed, 2 insertions, 1 deletions
diff --git a/g10/main.h b/g10/main.h
index c41d783ff..fa7adf06a 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -184,7 +184,8 @@ int collapse_uids( KBNODE *keyblock );
int parse_export_options(char *str,unsigned int *options);
int export_pubkeys( STRLIST users, unsigned int options );
-int export_pubkeys_stream( IOBUF out, STRLIST users, unsigned int options );
+int export_pubkeys_stream( IOBUF out, STRLIST users,
+ KBNODE *keyblock_out, unsigned int options );
int export_seckeys( STRLIST users );
int export_secsubkeys( STRLIST users );