aboutsummaryrefslogtreecommitdiffstats
path: root/g10/main.h
diff options
context:
space:
mode:
authorJustus Winter <[email protected]>2016-04-04 15:05:50 +0000
committerJustus Winter <[email protected]>2016-04-04 15:53:03 +0000
commitabb352de51bc964c06007fce43ed6f6caea87c15 (patch)
tree2086813d191c3387e1cf295adcfa7a85ae0a261d /g10/main.h
parenttests: Fix default key test. (diff)
downloadgnupg-abb352de51bc964c06007fce43ed6f6caea87c15.tar.gz
gnupg-abb352de51bc964c06007fce43ed6f6caea87c15.zip
g10: Support armored keyrings in gpgv.
* doc/gpgv.texi: Document the feature. * g10/Makefile.am (gpgv2_SOURCES): Add dearmor.c. * g10/dearmor.c (dearmor_file): Add sink argument. * g10/gpg.c (main): Adapt accordingly. * g10/gpgv.c (make_temp_dir): New function. (main): De-armor keyrings. * g10/main.h (dearmor_file): Adapt prototype. GnuPG-bug-id: 2290 Signed-off-by: Justus Winter <[email protected]>
Diffstat (limited to '')
-rw-r--r--g10/main.h2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/main.h b/g10/main.h
index 5b5947e48..766c53fd9 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -389,7 +389,7 @@ gpg_error_t receive_seckey_from_agent (ctrl_t ctrl, gcry_cipher_hd_t cipherhd,
gpg_error_t export_ssh_key (ctrl_t ctrl, const char *userid);
/*-- dearmor.c --*/
-int dearmor_file( const char *fname );
+int dearmor_file( const char *fname, int outfd );
int enarmor_file( const char *fname );
/*-- revoke.c --*/