aboutsummaryrefslogtreecommitdiffstats
path: root/g10/main.h
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
committerDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
commit06442ab0da6c119fb18ee8a19984ebac89e1fc75 (patch)
tree8e4dc3194719bcced63dfe52be4def9c9c3a5685 /g10/main.h
parent* Makefile.am: Add sc-copykeys program. (diff)
downloadgnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.tar.gz
gnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.zip
* packet.h, main.h, sig-check.c (signature_check2, check_key_signature2,
do_check): If ret_pk is set, fill in the pk used to verify the signature. Change all callers in getkey.c, mainproc.c, and sig-check.c. * keylist.c (list_keyblock_colon): Use the ret_pk from above to put the fingerprint of the signing key in "sig" records during a --with-colons --check-sigs. This requires --no-sig-cache as well since we don't cache fingerprints.
Diffstat (limited to '')
-rw-r--r--g10/main.h3
1 files changed, 2 insertions, 1 deletions
diff --git a/g10/main.h b/g10/main.h
index 8657bba60..285500ce4 100644
--- a/g10/main.h
+++ b/g10/main.h
@@ -129,7 +129,8 @@ int sign_symencrypt_file (const char *fname, STRLIST locusr);
int check_revocation_keys (PKT_public_key *pk, PKT_signature *sig);
int check_key_signature( KBNODE root, KBNODE node, int *is_selfsig );
int check_key_signature2( KBNODE root, KBNODE node, PKT_public_key *check_pk,
- int *is_selfsig, u32 *r_expiredate, int *r_expired );
+ PKT_public_key *ret_pk, int *is_selfsig,
+ u32 *r_expiredate, int *r_expired );
/*-- delkey.c --*/
int delete_keys( STRLIST names, int secret, int allow_both );