aboutsummaryrefslogtreecommitdiffstats
path: root/g10/keyserver.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-02-20 15:04:56 +0000
committerDavid Shaw <[email protected]>2004-02-20 15:04:56 +0000
commite867829de79eca53e23c66d753f8f53d20a8993f (patch)
treee890ed6d7db37856eaab15590ce0c64a7e373f08 /g10/keyserver.c
parent* gpgkeys_ldap.c: Replacement prototypes for setenv and unsetenv. (diff)
downloadgnupg-e867829de79eca53e23c66d753f8f53d20a8993f.tar.gz
gnupg-e867829de79eca53e23c66d753f8f53d20a8993f.zip
* mkdtemp.c: Removed.
* Makefile.am: We get mkdtemp.c from libutil.a now, so don't link with @LIBOBJS@. * keyserver.c (keyserver_spawn): Pass the scheme to the keyserver helper.
Diffstat (limited to 'g10/keyserver.c')
-rw-r--r--g10/keyserver.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/g10/keyserver.c b/g10/keyserver.c
index a651f7165..163d3bae0 100644
--- a/g10/keyserver.c
+++ b/g10/keyserver.c
@@ -1,5 +1,5 @@
/* keyserver.c - generic keyserver code
- * Copyright (C) 2001, 2002, 2003 Free Software Foundation, Inc.
+ * Copyright (C) 2001, 2002, 2003, 2004 Free Software Foundation, Inc.
*
* This file is part of GnuPG.
*
@@ -741,6 +741,7 @@ keyserver_spawn(int action,STRLIST list,
fprintf(spawn->tochild,"# This is a gpg keyserver communications file\n");
fprintf(spawn->tochild,"VERSION %d\n",KEYSERVER_PROTO_VERSION);
fprintf(spawn->tochild,"PROGRAM %s\n",VERSION);
+ fprintf(spawn->tochild,"SCHEME %s\n",opt.keyserver_scheme);
if(opt.keyserver_opaque)
fprintf(spawn->tochild,"OPAQUE %s\n",opt.keyserver_opaque);