aboutsummaryrefslogtreecommitdiffstats
path: root/g10/keyserver.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-07-30 16:48:21 +0000
committerDavid Shaw <[email protected]>2002-07-30 16:48:21 +0000
commit928dba9e708cf8955e32371b762fd47ea251ee3d (patch)
treecfd73a79b67490348d414c94781e44c6e6d8b836 /g10/keyserver.c
parent* README, configure.ac: --with-exec-path is now clarified into (diff)
downloadgnupg-928dba9e708cf8955e32371b762fd47ea251ee3d.tar.gz
gnupg-928dba9e708cf8955e32371b762fd47ea251ee3d.zip
* options.h, g10.c (main), mainproc.c (proc_encrypted): Return a
decryption failed error if a MDC does not verify. Warn if a MDC is not present (can disable via --no-mdc-warning). * exec.c (exec_write), g10.c (main), keyserver.c (keyserver_spawn): Use new DISABLE_KEYSERVER_PATH rather than FIXED_EXEC_PATH.
Diffstat (limited to 'g10/keyserver.c')
-rw-r--r--g10/keyserver.c9
1 files changed, 6 insertions, 3 deletions
diff --git a/g10/keyserver.c b/g10/keyserver.c
index 61c71569c..59e87c8c2 100644
--- a/g10/keyserver.c
+++ b/g10/keyserver.c
@@ -339,13 +339,16 @@ keyserver_spawn(int action,STRLIST list,
opt.keyserver_options.use_temp_files=1;
#endif
-#ifndef FIXED_EXEC_PATH
- /* Push the libdir into path */
+ /* Push the libexecdir into path. If DISABLE_KEYSERVER_PATH is set,
+ use the 0 arg to replace the path. */
+#ifdef DISABLE_KEYSERVER_PATH
+ set_exec_path(GNUPG_LIBEXECDIR,0);
+#else
set_exec_path(GNUPG_LIBEXECDIR,opt.exec_path_set);
#endif
- /* Build the filename for the helper to execute */
+ /* Build the filename for the helper to execute */
command=m_alloc(strlen("gpgkeys_")+strlen(opt.keyserver_scheme)+1);
strcpy(command,"gpgkeys_");
strcat(command,opt.keyserver_scheme);