aboutsummaryrefslogtreecommitdiffstats
path: root/g10/keyserver.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-07-04 16:06:38 +0000
committerDavid Shaw <[email protected]>2002-07-04 16:06:38 +0000
commit32b11e4501b31267cf0e311bfb9eb55db4515e54 (patch)
tree3ce7d41ac782a051ccce0d286a4301b968f647cb /g10/keyserver.c
parent* configure.ac: --enable-exec-path should be a 'with'. Fix 'no' cases of (diff)
downloadgnupg-32b11e4501b31267cf0e311bfb9eb55db4515e54.tar.gz
gnupg-32b11e4501b31267cf0e311bfb9eb55db4515e54.zip
* photoid.c (get_default_photo_command, show_photos): Honor
FIXED_PHOTO_VIEWER and DISABLE_PHOTO_VIEWER. * mainproc.c (check_sig_and_print): Use --show-photos to show photos when verifying a sig made by a key with a photo. * keyserver.c (parse_keyserver_uri): Properly parse a URI with no :port section and an empty file path, but with a terminating '/'. (keyserver_work): Honor DISABLE_KEYSERVER_HELPERS. * hkp.c (hkp_ask_import): Display keyserver URI as a URI, but only if verbose. * exec.c, g10.c: USE_EXEC_PATH -> FIXED_EXEC_PATH
Diffstat (limited to '')
-rw-r--r--g10/keyserver.c7
1 files changed, 6 insertions, 1 deletions
diff --git a/g10/keyserver.c b/g10/keyserver.c
index df7ef48e9..377418bec 100644
--- a/g10/keyserver.c
+++ b/g10/keyserver.c
@@ -148,7 +148,7 @@ parse_keyserver_uri(char *uri,const char *configname,unsigned int configlineno)
/* Get the host */
opt.keyserver_host=strsep(&uri,":/");
- if(uri==NULL)
+ if(uri==NULL || uri[0]=='\0')
opt.keyserver_port="0";
else
{
@@ -638,6 +638,11 @@ keyserver_work(int action,STRLIST list,KEYDB_SEARCH_DESC *desc,int count)
}
#endif
+#ifdef DISABLE_KEYSERVER_HELPERS
+ log_error(_("external keyserver calls are not supported in this build\n"));
+ return G10ERR_KEYSERVER;
+#endif
+
/* It's not the internal HKP code, so try and spawn a handler for it */
rc=keyserver_spawn(action,list,desc,count,&ret);