aboutsummaryrefslogtreecommitdiffstats
path: root/g10/keyedit.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2004-10-13 15:34:52 +0000
committerDavid Shaw <[email protected]>2004-10-13 15:34:52 +0000
commit9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce (patch)
treeaed46514ac8908373174ae052b2789a188ca6fbb /g10/keyedit.c
parent* configure.ac: Actually name the option --disable-finger and not (diff)
downloadgnupg-9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce.tar.gz
gnupg-9a4dc13d5e34fd93a2c2b59d99894c75eb3d4fce.zip
* pkclist.c (do_edit_ownertrust): Different prompt when we're using direct
trust since the meaning is different. * keyedit.c (trustsig_prompt): Change the strings to match the ones in pkclist.c:do_edit_ownertrust to make translation easier. * trustdb.c (trust_model_string, get_validity): Add direct trust model which applies to the key as a whole and not per-uid. * options.h, g10.c (parse_trust_model): New. (main): Call it from here to do string-to-trust-model.
Diffstat (limited to '')
-rw-r--r--g10/keyedit.c13
1 files changed, 6 insertions, 7 deletions
diff --git a/g10/keyedit.c b/g10/keyedit.c
index 43a683da5..a40ae1852 100644
--- a/g10/keyedit.c
+++ b/g10/keyedit.c
@@ -398,14 +398,13 @@ trustsig_prompt(byte *trust_value,byte *trust_depth,char **regexp)
*trust_depth=0;
*regexp=NULL;
- tty_printf("\n");
/* Same string as pkclist.c:do_edit_ownertrust */
- tty_printf(_(
- "Please decide how far you trust this user to correctly\n"
- "verify other users' keys (by looking at passports,\n"
- "checking fingerprints from different sources...)?\n\n"));
- tty_printf (_(" (%d) I trust marginally\n"), 1);
- tty_printf (_(" (%d) I trust fully\n"), 2);
+ tty_printf(_("Please decide how far you trust this user to correctly verify"
+ " other users' keys\n(by looking at passports, checking"
+ " fingerprints from different sources, etc.)\n"));
+ tty_printf("\n");
+ tty_printf (_(" %d = I trust marginally\n"), 1);
+ tty_printf (_(" %d = I trust fully\n"), 2);
tty_printf("\n");
while(*trust_value==0)