aboutsummaryrefslogtreecommitdiffstats
path: root/g10/keyedit.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
committerDavid Shaw <[email protected]>2003-03-04 15:24:12 +0000
commit909f6a0637b7111c294e5f6f37e4c3a0561bcd99 (patch)
treee1a4f448faaaee207c03d8813a15035c0e1c7f8b /g10/keyedit.c
parent* keyserver.c (keyserver_spawn): Include various pieces of information (diff)
downloadgnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.tar.gz
gnupg-909f6a0637b7111c294e5f6f37e4c3a0561bcd99.zip
* trustdb.c (validate_keys): Mask the ownertrust when building the list of
fully valid keys so that disabled keys are still counted in the web of trust. (get_ownertrust_with_min): Do the same for the minimum ownertrust calculation. * parse-packet.c (dump_sig_subpkt): Show the notation names for not-human-readable notations. Fix cosmetic off-by-one length counter. * options.skel: Add explantion and commented-out "no-mangle-dos-filenames". * mainproc.c (proc_encrypted): Make string translatable. * keyserver.c (keyserver_spawn): Quote ':', '%', and any 8-bit characters in the uid strings sent to the keyserver helper. * keyring.c (keyring_rebuild_cache): Lock the keyring while rebuilding the signature caches to prevent another gpg from tampering with the temporary copy. * keygen.c (keygen_set_std_prefs): Include AES192 and AES256 in default prefs. * keyedit.c (show_prefs): Make strings translatable. * keydb.c: Double the maximum number of keyrings to 40. * gpgv.c (main): Fix bug #113 - gpgv should accept the --ignore-time-conflict option. * g10.c (main): --openpgp disables --pgpX. Double the amount of secure memory to 32k (keys are getting bigger these days). * Makefile.am: Makefile.am: Use @CAPLIBS@ to link in -lcap if we are using capabilities.
Diffstat (limited to '')
-rw-r--r--g10/keyedit.c14
1 files changed, 9 insertions, 5 deletions
diff --git a/g10/keyedit.c b/g10/keyedit.c
index e34ee3aaa..671031466 100644
--- a/g10/keyedit.c
+++ b/g10/keyedit.c
@@ -1624,7 +1624,8 @@ show_prefs (PKT_user_id *uid, int verbose)
if (verbose) {
int any, des_seen=0, sha1_seen=0, uncomp_seen=0;
- tty_printf (" Cipher: ");
+ tty_printf (" ");
+ tty_printf (_("Cipher: "));
for(i=any=0; prefs[i].type; i++ ) {
if( prefs[i].type == PREFTYPE_SYM ) {
const char *s = cipher_algo_to_string (prefs[i].value);
@@ -1646,7 +1647,8 @@ show_prefs (PKT_user_id *uid, int verbose)
tty_printf (", ");
tty_printf ("%s",cipher_algo_to_string(CIPHER_ALGO_3DES));
}
- tty_printf ("\n Hash: ");
+ tty_printf ("\n ");
+ tty_printf (_("Digest: "));
for(i=any=0; prefs[i].type; i++ ) {
if( prefs[i].type == PREFTYPE_HASH ) {
const char *s = digest_algo_to_string (prefs[i].value);
@@ -1668,7 +1670,8 @@ show_prefs (PKT_user_id *uid, int verbose)
tty_printf (", ");
tty_printf ("%s",digest_algo_to_string(DIGEST_ALGO_SHA1));
}
- tty_printf ("\n Compression: ");
+ tty_printf ("\n ");
+ tty_printf (_("Compression: "));
for(i=any=0; prefs[i].type; i++ ) {
if( prefs[i].type == PREFTYPE_ZIP ) {
const char *s=compress_algo_to_string(prefs[i].value);
@@ -1696,7 +1699,8 @@ show_prefs (PKT_user_id *uid, int verbose)
}
if(uid->mdc_feature || !uid->ks_modify)
{
- tty_printf ("\n Features: ");
+ tty_printf ("\n ");
+ tty_printf (_("Features: "));
any=0;
if(uid->mdc_feature)
{
@@ -1707,7 +1711,7 @@ show_prefs (PKT_user_id *uid, int verbose)
{
if(any)
tty_printf (", ");
- tty_printf ("Keyserver no-modify");
+ tty_printf (_("Keyserver no-modify"));
}
}
tty_printf("\n");