aboutsummaryrefslogtreecommitdiffstats
path: root/g10/import.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2002-10-07 22:19:11 +0000
committerDavid Shaw <[email protected]>2002-10-07 22:19:11 +0000
commite4f5b9b4c2446c0c766bda018ef7e6d1d669985f (patch)
tree5dda6b651ab1db17c5d55b3f3c1253ebc84fa797 /g10/import.c
parent* configure.ac: OpenLDAP 2.0.27 changed the dependencies again. Add a (diff)
downloadgnupg-e4f5b9b4c2446c0c766bda018ef7e6d1d669985f.tar.gz
gnupg-e4f5b9b4c2446c0c766bda018ef7e6d1d669985f.zip
* import.c (import_keys_internal): Missed one s/inp/inp2/.
* keylist.c (print_capabilities): Properly indicate per-key capabilities of sign&encrypt primary keys that have secret-parts-missing (i.e. no capabilities at all) * mainproc.c (symkey_decrypt_sesskey): Fix compiler warning.
Diffstat (limited to 'g10/import.c')
-rw-r--r--g10/import.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/import.c b/g10/import.c
index 30ac913e2..1fa22d174 100644
--- a/g10/import.c
+++ b/g10/import.c
@@ -196,7 +196,7 @@ import_keys_internal( IOBUF inp, char **fnames, int nnames,
IOBUF inp2 = iobuf_open(fname);
if( !fname )
fname = "[stdin]";
- if( !inp )
+ if( !inp2 )
log_error(_("can't open `%s': %s\n"), fname, strerror(errno) );
else {
rc = import( inp2, fname, stats, options );