aboutsummaryrefslogtreecommitdiffstats
path: root/g10/import.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-04-23 21:18:39 +0000
committerDavid Shaw <[email protected]>2003-04-23 21:18:39 +0000
commit874214d0a0a0754d8fc48e57b066c778d3869e44 (patch)
treec2176ae3e2181f4069acf0652513e18261f4493b /g10/import.c
parent* Makefile.am, options.in: Rename options.in to options since it no longer (diff)
downloadgnupg-874214d0a0a0754d8fc48e57b066c778d3869e44.tar.gz
gnupg-874214d0a0a0754d8fc48e57b066c778d3869e44.zip
* import.c (import_revoke_cert): Remove ultimate trust when revoking an
ultimately trusted key. * keyedit.c (sign_uids): Allow replacing expired signatures. Allow duplicate signatures with --expert. * pkclist.c (check_signatures_trust): Don't display a null fingerprint when checking a signature with --always-trust enabled. * filter.h (progress_filter_context_t), progress.c (handle_progress), plaintext.c (ask_for_detached_datafile, hash_datafiles): Fix compiler warnings. Make "what" constant. * build-packet.c (do_plaintext): Do not create invalid literal packets with >255-byte names.
Diffstat (limited to 'g10/import.c')
-rw-r--r--g10/import.c7
1 files changed, 7 insertions, 0 deletions
diff --git a/g10/import.c b/g10/import.c
index 905e2d859..4fb6f5690 100644
--- a/g10/import.c
+++ b/g10/import.c
@@ -1105,6 +1105,13 @@ import_revoke_cert( const char *fname, KBNODE node, struct stats_s *stats )
m_free(p);
}
stats->n_revoc++;
+
+ /* If the key we just revoked was ultimately trusted, remove its
+ ultimate trust. This doesn't stop the user from putting the
+ ultimate trust back, but is a reasonable solution for now. */
+ if(get_ownertrust(pk)==TRUST_ULTIMATE)
+ clear_ownertrusts(pk);
+
revalidation_mark ();
leave: