aboutsummaryrefslogtreecommitdiffstats
path: root/g10/gpgv.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
committerDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
commit7c9855aaa2819c6774ba164f9991e9972556aa3f (patch)
tree038fbcf02207b726823576490906bac8a129f60e /g10/gpgv.c
parent* configure.ac: Define SAFE_VERSION so that RISCOS can override it and (diff)
downloadgnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.tar.gz
gnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.zip
* options.h, g10.c (main), keylist.c (list_keyblock_print): Add
"show-validity" and "show-long-keyid" list-options. * gpgv.c (get_validity, trust_value_to_string): Stubs. * g10.c (main): Use SAFE_VERSION instead of VERSION in the version-specific gpg.conf file so it can be overridden on RISCOS.
Diffstat (limited to 'g10/gpgv.c')
-rw-r--r--g10/gpgv.c12
1 files changed, 12 insertions, 0 deletions
diff --git a/g10/gpgv.c b/g10/gpgv.c
index 5f6f06710..67ecceabf 100644
--- a/g10/gpgv.c
+++ b/g10/gpgv.c
@@ -245,6 +245,18 @@ get_validity_info (PKT_public_key *pk, PKT_user_id *uid)
return '?';
}
+unsigned int
+get_validity (PKT_public_key *pk, PKT_user_id *uid)
+{
+ return 0;
+}
+
+const char *
+trust_value_to_string (unsigned int value)
+{
+ return "err";
+}
+
/* Stub: */
int
get_ownertrust_info (PKT_public_key *pk)