diff options
author | David Shaw <[email protected]> | 2009-06-05 14:11:03 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2009-06-05 14:11:03 +0000 |
commit | 047d97e95e1df831d699fb77cd58c269a13a5c5c (patch) | |
tree | 1aba8b3a366cbf6bfe543401009358b079ef3673 /g10/gpg.c | |
parent | * defs.inc: Improved all_cipher_algos and all_hash_algos to work when (diff) | |
download | gnupg-047d97e95e1df831d699fb77cd58c269a13a5c5c.tar.gz gnupg-047d97e95e1df831d699fb77cd58c269a13a5c5c.zip |
Add full Camellia support.
* configure.ac: Remove Camellia restriction.
* gpg.c (main), misc.c (openpgp_cipher_test_algo): Remove Camellia
restriction.
* misc.c (map_cipher_openpgp_to_gcry), main.h: Add macros for
openpgp_cipher_open, openpgp_cipher_get_algo_keylen, and
openpgp_cipher_get_algo_blklen to wrap around the corresponding gcry_*
functions, but pass the algorithm number through
map_cipher_openpgp_to_gcry. This is needed in case the gcry algorithm
number doesn't match the OpenPGP number (c.f. Camellia).
* encr-data.c, pubkey-enc.c, mainproc.c, cipher.c, encode.c, seskey.c,
passphrase.c, seckey-cert.c: Use new openpgp_cipher_* macros here.
Diffstat (limited to 'g10/gpg.c')
-rw-r--r-- | g10/gpg.c | 12 |
1 files changed, 1 insertions, 11 deletions
@@ -1,6 +1,6 @@ /* gpg.c - The GnuPG utility (main for gpg) * Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005, - * 2006, 2007, 2008 Free Software Foundation, Inc. + * 2006, 2007, 2008, 2009 Free Software Foundation, Inc. * * This file is part of GnuPG. * @@ -2963,15 +2963,6 @@ main (int argc, char **argv) log_set_prefix (NULL, 1|2|4); } -#ifdef USE_CAMELLIA - /* We better also print a runtime warning if people build it with - support for Camellia (which is not yet defined by OpenPGP). */ - log_info ("WARNING: This version has been built with support for the " - "Camellia cipher.\n"); - log_info (" It is for testing only and is NOT for production " - "use!\n"); -#endif - /* Older Libgcrypts fail with an assertion during DSA key generation. Better disable DSA2 entirely. */ if (opt.flags.dsa2 && !gcry_check_version ("1.4.0") ) @@ -4323,4 +4314,3 @@ add_keyserver_url( const char *string, int which ) if(critical) sl->flags |= 1; } - |