diff options
author | David Shaw <[email protected]> | 2005-11-06 04:32:54 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2005-11-06 04:32:54 +0000 |
commit | f48ef0f1f0b9557898d394990fd0342127ab7ea8 (patch) | |
tree | 931488b13b5de0fc3f69d9f42656f10377a737ae /g10/gpg.c | |
parent | * libusb.m4: Check for libusb-config and if we find it, use --libs and (diff) | |
download | gnupg-f48ef0f1f0b9557898d394990fd0342127ab7ea8.tar.gz gnupg-f48ef0f1f0b9557898d394990fd0342127ab7ea8.zip |
* Makefile.am: Include @LIBUSB_CPPFLAGS@ in our CPPFLAGS. Strictly
speaking this should be only in gpg_CPPFLAGS, but then we have to
compile everything twice for gpg and gpgv.
* apdu.c (open_pcsc_reader): Fix double free.
* gpg.c (main) [__APPLE__]: Default the PCSC driver to the OS X
location. Suggested by Patty A. Hardy.
Diffstat (limited to '')
-rw-r--r-- | g10/gpg.c | 4 |
1 files changed, 3 insertions, 1 deletions
@@ -1711,7 +1711,9 @@ main (int argc, char **argv ) #ifdef ENABLE_CARD_SUPPORT #if defined(_WIN32) || defined(__CYGWIN__) - opt.pcsc_driver = "winscard.dll"; + opt.pcsc_driver = "winscard.dll"; +#elif defined(__APPLE__) + opt.pcsc_driver = "/System/Library/Frameworks/PCSC.framework/PCSC"; #else opt.pcsc_driver = "libpcsclite.so"; #endif |