aboutsummaryrefslogtreecommitdiffstats
path: root/g10/getkey.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2006-03-01 18:16:55 +0000
committerDavid Shaw <[email protected]>2006-03-01 18:16:55 +0000
commit78904c691c1e573322a2d5eff06c7e38553ebd36 (patch)
tree8e105347e4dd616cb0a07ab0a8bce02f46e67ff2 /g10/getkey.c
parent* configure.ac: Fix accidental enabling of SHA-384/512. Noted by Nelson (diff)
downloadgnupg-78904c691c1e573322a2d5eff06c7e38553ebd36.tar.gz
gnupg-78904c691c1e573322a2d5eff06c7e38553ebd36.zip
* getkey.c (parse_auto_key_locate): Error if the user selects "cert" or
"pka" when those features are disabled. * misc.c (has_invalid_email_chars): Fix some C syntax that broke the compilers on SGI IRIX MIPS and Compaq/DEC OSF/1 Alpha. Noted by Nelson H. F. Beebe.
Diffstat (limited to '')
-rw-r--r--g10/getkey.c14
1 files changed, 9 insertions, 5 deletions
diff --git a/g10/getkey.c b/g10/getkey.c
index 6c64c77f8..8664c0f0a 100644
--- a/g10/getkey.c
+++ b/g10/getkey.c
@@ -2928,14 +2928,18 @@ parse_auto_key_locate(char *options)
akl=xmalloc_clear(sizeof(*akl));
- if(ascii_strcasecmp(tok,"cert")==0)
- akl->type=AKL_CERT;
- else if(ascii_strcasecmp(tok,"pka")==0)
- akl->type=AKL_PKA;
- else if(ascii_strcasecmp(tok,"ldap")==0)
+ if(ascii_strcasecmp(tok,"ldap")==0)
akl->type=AKL_LDAP;
else if(ascii_strcasecmp(tok,"keyserver")==0)
akl->type=AKL_KEYSERVER;
+#ifdef USE_DNS_CERT
+ else if(ascii_strcasecmp(tok,"cert")==0)
+ akl->type=AKL_CERT;
+#endif
+#ifdef USE_DNS_PKA
+ else if(ascii_strcasecmp(tok,"pka")==0)
+ akl->type=AKL_PKA;
+#endif
else if((akl->spec=parse_keyserver_uri(tok,1,NULL,0)))
akl->type=AKL_SPEC;
else