aboutsummaryrefslogtreecommitdiffstats
path: root/g10/getkey.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
committerDavid Shaw <[email protected]>2003-07-20 00:10:13 +0000
commit06442ab0da6c119fb18ee8a19984ebac89e1fc75 (patch)
tree8e4dc3194719bcced63dfe52be4def9c9c3a5685 /g10/getkey.c
parent* Makefile.am: Add sc-copykeys program. (diff)
downloadgnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.tar.gz
gnupg-06442ab0da6c119fb18ee8a19984ebac89e1fc75.zip
* packet.h, main.h, sig-check.c (signature_check2, check_key_signature2,
do_check): If ret_pk is set, fill in the pk used to verify the signature. Change all callers in getkey.c, mainproc.c, and sig-check.c. * keylist.c (list_keyblock_colon): Use the ret_pk from above to put the fingerprint of the signing key in "sig" records during a --with-colons --check-sigs. This requires --no-sig-cache as well since we don't cache fingerprints.
Diffstat (limited to '')
-rw-r--r--g10/getkey.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/getkey.c b/g10/getkey.c
index 4dd8085b8..f488eb04a 100644
--- a/g10/getkey.c
+++ b/g10/getkey.c
@@ -1604,7 +1604,7 @@ merge_selfsigs_main( KBNODE keyblock, int *r_revoked )
ultimate trust flag. */
if(get_pubkey_fast(ultimate_pk,sig->keyid)==0
&& check_key_signature2(keyblock,k,ultimate_pk,
- NULL,&dummy,&dum2)==0
+ NULL,NULL,&dummy,&dum2)==0
&& get_ownertrust(ultimate_pk)==TRUST_ULTIMATE)
{
free_public_key(ultimate_pk);