aboutsummaryrefslogtreecommitdiffstats
path: root/g10/g10.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
committerWerner Koch <[email protected]>2003-10-25 14:17:24 +0000
commitbc45e6e065f080d4cd47cbcecb61195b74293079 (patch)
tree95572974fd3ef83a1fa9c918cb0a3c60af20a336 /g10/g10.c
parent* configure.ac (DLLIBS): Work properly on platforms where dlopen and (diff)
downloadgnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.tar.gz
gnupg-bc45e6e065f080d4cd47cbcecb61195b74293079.zip
* g10.c (main) [ENABLE_CARD_SUPPORT]: Add a default for
--pcsc-driver. * cardglue.c (learn_status_cb): Fixed faulty use of !space.
Diffstat (limited to 'g10/g10.c')
-rw-r--r--g10/g10.c8
1 files changed, 8 insertions, 0 deletions
diff --git a/g10/g10.c b/g10/g10.c
index b63987989..0f6003565 100644
--- a/g10/g10.c
+++ b/g10/g10.c
@@ -1218,6 +1218,14 @@ main( int argc, char **argv )
if( !*opt.homedir )
set_homedir ( GNUPG_HOMEDIR );
+#ifdef ENABLE_CARD_SUPPORT
+# ifdef _WIN32
+ opt.pcsc_driver = "winscard.dll";
+#else
+ opt.pcsc_driver = "libpcsclite.so";
+#endif
+#endif /*ENABLE_CARD_SUPPORT*/
+
/* check whether we have a config file on the commandline */
orig_argc = argc;
orig_argv = argv;