diff options
author | David Shaw <[email protected]> | 2003-10-31 05:39:02 +0000 |
---|---|---|
committer | David Shaw <[email protected]> | 2003-10-31 05:39:02 +0000 |
commit | 869c6bb7e455c91680bad8c2649bcfcdacfc4e7d (patch) | |
tree | 02e5d7eaacfbe5dfd6f5485b73c24f0332638877 /g10/g10.c | |
parent | * cipher.h: Add COMPRESS_ALGO_BZIP2. (diff) | |
download | gnupg-869c6bb7e455c91680bad8c2649bcfcdacfc4e7d.tar.gz gnupg-869c6bb7e455c91680bad8c2649bcfcdacfc4e7d.zip |
* misc.c (compress_algo_to_string, string_to_compress_algo,
check_compress_algo): Add bzip2.
* compress.c (compress_filter): Make static to help force the use of
push_compress_filter. Remove default algorithm setting since that is done
in push_compress_filter now.
* main.h: Use named algorithm.
* filter.h, compress.c (push_compress_filter, push_compress_filter2): New.
Figure out which is the appropriate compression filter to use, and push it
into place.
* compress.c (handle_compressed), encode.c (encode_simple, encode_crypt),
sign.c (sign_file, sign_symencrypt_file), import.c (read_block), export.c
(do_export): Use push_compress_filter instead of pushing the compression
filter ourselves.
* compress-bz2.c: New. Bzlib versions of the compression filter routines.
* Makefile.am: Include compress-bz2.c if bz2lib is available.
Diffstat (limited to 'g10/g10.c')
-rw-r--r-- | g10/g10.c | 3 |
1 files changed, 2 insertions, 1 deletions
@@ -2485,7 +2485,8 @@ main( int argc, char **argv ) break; case aEncrSym: - /* This works with PGP 8. It doesn't work with 2 or 6. It + /* This works with PGP 8 in the sense that it acts just like a + symmetric message. It doesn't work at all with 2 or 6. It might work with 7, but alas, I don't have a copy to test with right now. */ if( argc > 1 ) |