aboutsummaryrefslogtreecommitdiffstats
path: root/g10/g10.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
committerDavid Shaw <[email protected]>2003-06-03 17:47:58 +0000
commit7c9855aaa2819c6774ba164f9991e9972556aa3f (patch)
tree038fbcf02207b726823576490906bac8a129f60e /g10/g10.c
parent* configure.ac: Define SAFE_VERSION so that RISCOS can override it and (diff)
downloadgnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.tar.gz
gnupg-7c9855aaa2819c6774ba164f9991e9972556aa3f.zip
* options.h, g10.c (main), keylist.c (list_keyblock_print): Add
"show-validity" and "show-long-keyid" list-options. * gpgv.c (get_validity, trust_value_to_string): Stubs. * g10.c (main): Use SAFE_VERSION instead of VERSION in the version-specific gpg.conf file so it can be overridden on RISCOS.
Diffstat (limited to 'g10/g10.c')
-rw-r--r--g10/g10.c4
1 files changed, 3 insertions, 1 deletions
diff --git a/g10/g10.c b/g10/g10.c
index ecd9c9b46..8a7f09d13 100644
--- a/g10/g10.c
+++ b/g10/g10.c
@@ -1260,7 +1260,7 @@ main( int argc, char **argv )
{
/* Try for a version specific config file first */
configname = make_filename(opt.homedir,
- "gpg" EXTSEP_S "conf-" VERSION, NULL );
+ "gpg" EXTSEP_S "conf-" SAFE_VERSION, NULL );
if(access(configname,R_OK))
{
m_free(configname);
@@ -1752,6 +1752,8 @@ main( int argc, char **argv )
{"show-policy-url",LIST_SHOW_POLICY},
{"show-notation",LIST_SHOW_NOTATION},
{"show-keyring",LIST_SHOW_KEYRING},
+ {"show-validity",LIST_SHOW_VALIDITY},
+ {"show-long-keyid",LIST_SHOW_LONG_KEYID},
{NULL,0}
};