aboutsummaryrefslogtreecommitdiffstats
path: root/g10/g10.c
diff options
context:
space:
mode:
authorDavid Shaw <[email protected]>2003-02-22 13:00:18 +0000
committerDavid Shaw <[email protected]>2003-02-22 13:00:18 +0000
commit6f41d068418ca9a9ff7541d5fafc1fcdb20804cf (patch)
tree4f508a2ed6846271970e2ee48cd0bcb77db6c087 /g10/g10.c
parent* configure.ac: Add --disable-xxx options for CAST5, BLOWFISH, AES (all), (diff)
downloadgnupg-6f41d068418ca9a9ff7541d5fafc1fcdb20804cf.tar.gz
gnupg-6f41d068418ca9a9ff7541d5fafc1fcdb20804cf.zip
* g10.c (main): Accept "s1" in addition to "idea" to match the other
ciphers. * main.h, misc.c (idea_cipher_warn): We don't need this if IDEA has been disabled.
Diffstat (limited to '')
-rw-r--r--g10/g10.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/g10/g10.c b/g10/g10.c
index 3f1126e82..e98e7b71d 100644
--- a/g10/g10.c
+++ b/g10/g10.c
@@ -1984,7 +1984,8 @@ main( int argc, char **argv )
if( def_cipher_string ) {
opt.def_cipher_algo = string_to_cipher_algo(def_cipher_string);
if(opt.def_cipher_algo==0 &&
- ascii_strcasecmp(def_cipher_string,"idea")==0)
+ (ascii_strcasecmp(def_cipher_string,"idea")==0
+ || ascii_strcasecmp(def_cipher_string,"s1")==0))
idea_cipher_warn(1);
m_free(def_cipher_string); def_cipher_string = NULL;
if( check_cipher_algo(opt.def_cipher_algo) )