aboutsummaryrefslogtreecommitdiffstats
path: root/g10/g10.c
diff options
context:
space:
mode:
authorWerner Koch <[email protected]>2003-10-21 18:22:21 +0000
committerWerner Koch <[email protected]>2003-10-21 18:22:21 +0000
commit441aeb85f21436b1ae2ecd1de420138016baba57 (patch)
treefc1c2ed359f38e7700ef53c0872117f571712d4b /g10/g10.c
parent* configure.ac: Include -ldl when card support is used. (diff)
downloadgnupg-441aeb85f21436b1ae2ecd1de420138016baba57.tar.gz
gnupg-441aeb85f21436b1ae2ecd1de420138016baba57.zip
* passphrase.c (ask_passphrase): Add optional promptid arg.
Changed all callers. * cardglue.c (pin_cb): Use it here, so the machine interface can tell whether the Admin PIN is requested. * cardglue.c (agent_scd_checkpin): New. * misc.c (openpgp_pk_algo_usage): Added AUTH usage. * app-openpgp.c (check_against_given_fingerprint): New. Factored out that code elsewhere. (do_check_pin): New. * card-util.c (card_edit): New command "passwd". Add logic to check the PIN in advance. (card_status): Add new args to return the serial number. Changed all callers.
Diffstat (limited to '')
-rw-r--r--g10/g10.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/g10/g10.c b/g10/g10.c
index 60a6aaef4..b63987989 100644
--- a/g10/g10.c
+++ b/g10/g10.c
@@ -2914,7 +2914,7 @@ main( int argc, char **argv )
case aCardStatus:
if (argc)
wrong_args ("--card-status");
- card_status (stdout);
+ card_status (stdout, NULL, 0);
break;
case aCardEdit: